Blender problems

0

Hi all.

Using Blender 2.8, I have run in this issue with several models, so I am guessing it's something trivial and common.

For example, if I try and enlarge the tmd turrets of the Cybran battleship, and rearrange the barrels and muzzles from their current vertical positioning to a horizontal one, I can export the model without errors but as soon as i cheat spawn it in game, the game will freeze.

Now, i know it's a mesh issue because it does not freeze if I am fully zoomed out, but as soon as i start zooming in (the model turns from an icon to a model), nope, freeze.

I have tried merging vertices by distance of the entire mesh (seem to have read somewhere about that), which step am I missing??

Seeing as how I have ran at the same exact issue on several units I tried editing, i am fairly certain it's a very common thing.

But what is it, what am I forgetting?

This thing pretty much kills my every attempt to create something 😞 And it's annoying as fuck, because I just know it's something stupid and minor and solvable in 3 clicks

0

Best place to aske is probs on the Creative Discord https://discord.gg/VMhM2N8 your more of a chance to get a faster responce in helping with this issuse you are having

0

doesn't sound like a common problem to me what does the game log say?

0

Bones likely died or you didn’t change the less detailed Lod and game gets confused

0

Logs are useless when the game crashes, the log file is not updated with the culprit. (i have to ctrl-alt-del out of windows cause game freezes completely).

Can you elaborate what bones dissolving means?

Vertex groups are paired up with their bones, everything is moving the parts it needs to, in Pose mode.

0

check the game log most likely found in programdata/faforever/logs

0

@MadMax there is no log data when the game freezes. The last line in the log is the one BEFORE the game crashes and does not contain the actual error that caused the entire thing to freeze. Unfortunately....that's the first thing I went to, the logs.

Freeze as in i need a computer restart.

Ok here's what I got so far.

  • I select a turret that has a body, 2 barrels, and 5 total bones (+2 for muzzle spots),
  • shift-d duplicate it,
  • move it on the other spot of the mesh,
  • I then remove the vertex groups (that have also been duplicated, so now the same group is on the original and on the duplicate)
  • I assign to the old vertex groups only the original parts of the turret, like it was before the duplication
  • I make second groups for the duplicate vertices with different naming
  • I create 5 more bones and place them and name them according to the second group of vertices
  • I test everything in Pose mode, old 5 bones move parts of the old turret, new 5 bones move only the duplicated parts of the turret
  • all new bones connected like they should

So... vertex groups have been set like they should, bones have been set like they should, all is named like it should AND THAT IS THE ONLY CHANGE TO THE MESH - I go in game, game freezes as soon as I start zooming on the unit.

All I did was duplicate a goddamn turret....

Log in to reply