On Linux can not lauch game with run file

I have launched the game through steam with the following launch options


then ran the two protontricks commands recommended in the wiki and they seem to complete without error. There is a warning about wine 32-bit prefixs

./protontricks 9420 dlls d3dx9
./protontricks 9420 dlls xact

After these two steps game runs fine when launching from steam. However trying to launch from the generated run file produces a black screen. The black screen seems to be a mechanically working menu since I can click in game buttons. Just not visually.

Step 8 of the wiki says "in which you edit out steam.exe" which I have not done as I am not quiet sure what it means. So may be the problem.

I am running this on the manjaro distro with amd opensouce gpu drivers.

If anyone has encountered this before I would greatly appreciate if you have a solution😁


my bro needs help from intelligent people!

This is where you put those flags?
I would also try without PROTON_USE_WINED3D=1.
Next thing I would try do redefine DEF_CMD in run script to point to FAF's exe
i.e. DEF_CMD=("/home/manjaro/kubo/.faforever/bin/ForgedAlliance.exe")

@kubkolienka sorry for the slow reply I have been tied up with family matters.

I have tried removing the PROTON_USE_WINED3D=1

This causes this error to pop up when running the run file. When running from steam it makes the intro cut scene run about a frame a second


I am running using the opensource video-linux drivers for amd

I then tried changing the DEF_CMD too DEF_CMD=("/home/nogthar/.faforever/bin/ForgedAlliance.exe"). Seems to still load into a blank window. When I hover the mouse over the window it makes the audio noises of the buttons and shows the correct mouse cursor.


I appreciate the help and please let me know if you have any other ideas 😃

which proton do you use? there is an unpleasant feature since version 4.x.x requires a running steam; if you open the RUN file there is a mention in the last lines "steam.exe "; if you do not run steam, then the emulation does not pass d3d does not work out such errors fly out.(well, or so I understood it)
of course, you can run steam for the test and if the problem is solved, simply edit the startup file eliminating the need for steam

at least your screenshots reminded me of exactly this problem that I once struggled with.

last 5 lines run file (proton 4.11)
"/home/user/.steam/debian-installation/steamapps/common/Proton 4.11/dist/bin/wine" "${@:-${DEF_CMD[@]}}"

WINEDLLOVERRIDES="..." - must not contain arguments "steam"
STEAM_COMPAT_CLIENT_INSTALL_PATH="..." - must not contain "steam.exe" between words .../wine" and "${@:-${DEF_CMD[@]}}"

@nogthar it looks like PROTON_NO_ESYNC=1 PROTON_NO_FSYNC=1 is not applied somehow. Could you post your whole run file?

@kubkolienka Here is the run file as generated. This is without the change to DEF_CMD

#Run game or given command in environment

cd "/home/nogthar/.local/share/Steam/steamapps/common/Supreme Commander Forged Alliance"
DEF_CMD=("/home/nogthar/.local/share/Steam/steamapps/common/Supreme Commander Forged Alliance/bin/SupremeCommander.exe")
PATH="/home/nogthar/.local/share/Steam/steamapps/common/Proton - Experimental/files/bin/:/usr/bin:/bin" \
	TERM="xterm" \
	WINEDEBUG="-all" \
	WINEDLLPATH="/home/nogthar/.local/share/Steam/steamapps/common/Proton - Experimental/files/lib64//wine:/home/nogthar/.local/share/Steam/steamapps/common/Proton - Experimental/files/lib//wine" \
	LD_LIBRARY_PATH="/home/nogthar/.local/share/Steam/ubuntu12_64/video/:/home/nogthar/.local/share/Steam/ubuntu12_32/video/:/home/nogthar/.local/share/Steam/steamapps/common/Proton - Experimental/files/lib64/:/home/nogthar/.local/share/Steam/steamapps/common/Proton - Experimental/files/lib/:/usr/lib/pressure-vessel/overrides/lib/x86_64-linux-gnu/aliases:/usr/lib/pressure-vessel/overrides/lib/i386-linux-gnu/aliases" \
	WINEPREFIX="/home/nogthar/.local/share/Steam/steamapps/compatdata/9420/pfx/" \
	SteamGameId="9420" \
	SteamAppId="9420" \
	WINEDLLOVERRIDES="steam.exe=b;dotnetfx35.exe=b;beclient.dll=b,n;beclient_x64.dll=b,n" \
	STEAM_COMPAT_CLIENT_INSTALL_PATH="/home/nogthar/.local/share/Steam" \
	GST_PLUGIN_SYSTEM_PATH_1_0="/home/nogthar/.local/share/Steam/steamapps/common/Proton - Experimental/files/lib64/gstreamer-1.0:/home/nogthar/.local/share/Steam/steamapps/common/Proton - Experimental/files/lib/gstreamer-1.0" \
	WINE_GST_REGISTRY_DIR="/home/nogthar/.local/share/Steam/steamapps/compatdata/9420/gstreamer-1.0/" \
	MEDIACONV_AUDIO_DUMP_FILE="/home/nogthar/.local/share/Steam/steamapps/shadercache/9420/fozmediav1/audiov2.foz" \
	MEDIACONV_AUDIO_TRANSCODED_FILE="/home/nogthar/.local/share/Steam/steamapps/shadercache/9420/transcoded_audio.foz" \
	MEDIACONV_VIDEO_DUMP_FILE="/home/nogthar/.local/share/Steam/steamapps/shadercache/9420/fozmediav1/video.foz" \
	MEDIACONV_VIDEO_TRANSCODED_FILE="/home/nogthar/.local/share/Steam/steamapps/shadercache/9420/transcoded_video.foz" \
	"/home/nogthar/.local/share/Steam/steamapps/common/Proton - Experimental/files/bin/wine64" c:\\windows\\system32\\steam.exe "${@:-${DEF_CMD[@]}}"

@fractal switching to proton 4.11-13 seemed to be the solution. Now when running the run file in terminal or having it launched by the faf client it works.

Thanks @kubkolienka and @fractal for your time! I really appreciate the help!

@fractal do I understand it right, that those who need to run it with D3D instead of vulkan needs proton 4.11?

When I set it up I think that proton 5.x worked as well, but I did have issues with the later proton versions.

@kubkolienka you're right. Vulcan support starts with Proton version 5.

@askaholic the performance of each version of proton strongly depends on your hardware. (gpu)
that's why Valve fixes so many builds.
progress does not stand still, all sorts of new technologies appear (RTS, FSR, etc.) this is reflected in the GPU-supported specific version of proton.
(in general terms, something like this)

@nogthar no problems. glad I was helpful.

by the way 🙂 you can use HTOP to order the game to run on all processor cores, or on a more productive one. This is useful for those who have every CPU rating point on their account.
launch HTOP, find the game process. click "a" and select cores/threads.
there are other ways, but this one is the simplest, fastest, without serious interference with the kernel process scheduler and writing startup scripts.
the profit is that if you roll the game straining all the cores / threads, the processor chip of the chiplet architecture warms up more evenly. Well, if 0/1 core / thread is not the most productive, you can fix the situation.