Problem when trying to update to the latest FAF Client

I tried updating to the latest FAF client release on 29/04/2022.

Part way through the update I got an error message.

"C:\Program Files\Downlord's FAF Client.install4j\i4j_extf_10_4k8v4f_18gg8kx.png
Could not create this file. Shall I try again?"

I clicked "yes" a few times but it didn't help so then I clicked "cancel".

Now I have no FAF shortcut on my desktop and I don't know what state the FAF update is in.

I have updated the FAF client numerous times in the past without having problems.

What should I do now ?


  1. Do you have enough disc space?
  2. Have you tried to install it to a different disc drive?

I do have enough disk space. 404 GB free of 476 GB.

I have not tried to install it to a different disc drive.

I don't know how to re-run the FAF Client Install now that the update has failed.

File C:\Program Files\Downlord's FAF Client.install4j\i4j_extf_10_4k8v4f_18gg8kx.png
is present on my drive despite the error message saying it could not be created.

There are four files in total similar to this. They appear to be monitor icons with different shades of blue.

I would just try manually deleting the install folder and trying again. Likely something went wrong with file permissions

Looks like the underlying problem was caused by Norton Antivirus Data Protector.

I deleted the old 'C:\Program Files\Downlord's FAF Client' folder and down loaded the latest FAF client installer from

When I tried to run this I got a "Data Protector blocked a suspicious action by faf_windows-x64_2022_4_0(1).exe" message.

I managed to get Norton to exclude this process and then everything seemed to run okay.

2022-04-29 (1).png

This post is deleted!