FAF client completely unusable on VRR display due to screen flickering.

Hi. The FAF client is royally messing up with my variable refresh rate screen. The refresh rate is all over the place with FAF client being the active window and that causes massive spikes in brightness resulting in very bad flickering. By default I play all my games in borderless windowed mode so I have the VRR applied to that mode too and I don't feel like changing it for just one game. Any way to solve this? I tried applying an fps limiter through Nvidia control panel and RTSS but it seems to have no effect. I could temporarily change Nvidia settings to only apply VRR to fullscreen mode but that's only a temporary solution 😕 Some other games I like I literally can't play in fullscreen because they'll softlock my pc if I alt tab out of them. Since everything else works good and FAF client isn't really doing anything graphically demanding I'm forced to believe the issue is with the client itself.

Is there any reason to not want to have the highest rate at all times?
What is the benefit of VRR for you?

Edit: I think here is a mixed up between FPS and refresh rate (monitor screen)

You always want the highest refresh rate for your monitor.

You can limit the FPS to any window/game with certain tools.

fps limiter through Nvidia control panel and RTSS... seems to have no effect...

Have you actually checked the FPS values for the game, or is it just 'some gut feeling' ? Have you tried other tools via Google?

Some other games I like I literally can't play in fullscreen because they'll softlock my pc if I alt tab out of them

I am not sure if the FAF client is the issue here.

VRR is useful for eliminating screen tearing, besides, it's not like I can disable it for just one application, it's impossible and disabling or enabling it globally requires a reboot which means it's not a viable option at all.

You don't always want the highest refresh rate of your monitor, google VRR and see what it does. Although in case of faf client it should indeed run at 144hz, this is what other windowed applications such as chrome, nvidia control panel, msi afterburner or RTSS do.

I tried the two most reliable fps limiters and while on closer inspection they seem to actually work (if I set the limit to 1 fps I can see how slowly faf client reacts to my mouse movement) the flickering still persists.

Every other windowed application works fine and faf is just a flat, static window with some text and occasional picture or two so I can only conclude there is something wrong with it. No idea what, but surely there must be some difference in comparison to every other windowed app I'm running that causes the problem.

For now I disabled VRR for windowed applications since it seems that the main game I'm using it for somehow still has access to it despite running in borderless window mode. But still some devs may wanna have a look at that.

I do not run VRR and don't know if any of the other client devs do either. So we cannot reproduce the bug, and as this seems to be an isolated setup issue as this is the first I have heard of it.
I would not anticipate this being looked into any time soon, unless someone who actively has the problem decides to fix it in the source themself.

Could you provide some more details? Do you mean "G-SYNC" or "GSYNC compatible" when you talk about VRR?

I have a GTX 1060 and i am happily using it with a "FreeSync Premium" monitor (GIGABYTE M27Q). Works just fine as GSYNC compatible monitor. I enabled the "G-SYNC indicator" in the NVidia Control Panel Menu, and it is shown on the client:


Running another game at the same time:

So yeah, we would need more information about your setup, hardware, and NVidia settings. Note that i am always using NVidias FPS limiter set 10 Hz below my monitor max refresh rate (unless is can use a game's native limiter).

However, if you just want a quick fix, you can start client in software rendering mode, but this will create quite a bit of CPU load while running the client. Open C:\Program Files\Downlord's FAF Client\faf-client.vmoptions in an editor and add the line -Dprism.order=sw. If this doesn't fix it, the client is very unlikely to be the problem.

Unfortunately, I couldn't find that Downlord's Faf Client folder anywhere on my drives. I'm using AOC Q32G1.

It is just FAF Client now