Unable to host custom games - any advice?


Something is killing your connection to the server and the api before the game can launch.

See the error message below. I would think it is anti virus or something about your network connections

2021-12-24 02:02:21.848  INFO 11796 --- [JavaFX Application Thread] c.f.client.remote.FafServerAccessor      : Closing lobby server connection
2021-12-24 02:02:21.849  INFO 11796 --- [JavaFX Application Thread] com.faforever.commons.lobby.FafLobbyApi  : Disconnecting from server
2021-12-24 02:02:21.849  INFO 11796 --- [JavaFX Application Thread] com.faforever.commons.lobby.FafLobbyApi  : Outbound channel closed
2021-12-24 02:02:21.853  INFO 11796 --- [reactor-tcp-nio-2] com.faforever.commons.lobby.FafLobbyApi  : Disconnected from server
2021-12-24 02:02:21.853 DEBUG 11796 --- [pool-3-thread-1] com.faforever.client.theme.UiService     : Watcher service terminated
2021-12-24 02:02:21.862  WARN 11796 --- [reactor-http-nio-12] r.netty.http.client.HttpClientConnect    : [id:99bd53de-1, L:/ ! R:api.faforever.com/] The connection observed an error

reactor.netty.http.client.PrematureCloseException: Connection prematurely closed BEFORE response

2021-12-24 02:02:21.866 ERROR 11796 --- [reactor-http-nio-12] c.f.client.game.CreateGameController     : Error when updating the map

java.util.concurrent.CompletionException: org.springframework.web.reactive.function.client.WebClientRequestException: Connection prematurely closed BEFORE response; nested exception is reactor.netty.http.client.PrematureCloseException: Connection prematurely closed BEFORE response

To me it looks like you are closing your client while it is trying to start the game which is odd. But that is why I think it is some anti virus or something shutting down the client


Hmm. I'm using Windows defender, default rules.

Any ideas about why this is an issue now, and was not an issue on 1.5.0 and before?


I tried a few things:

  • Reset windows defender firewall settings to defaults
  • Turn off firewall
  • Run the FAF client from master (89bcab)
  • Turn off anti-virus real-time protection

Same results as before - no custom game launched.

Happy to provide more logs. Now that I'm on master, I can easily test specific commits.


Hmm if you are running from source you should be able see the logs more clearly. Also the updated branch is develop not master. So checkout that one. Also the only thing that changed between 1.5.0 and later is we changed the backed library we use for the tcp connections


OK - thanks for the info. It seems I was on develop all along, I guess I typed "master" out of habit.

if you are running from source you should be able see the logs more clearly

Should I just copy stdout? Loglevel debug? From what I could see last time, stdout looked similar to what I found in client.log. Any other information we need to understand what's going on?

(Sorry for the fragmented process. I have a Windows computer for playing FAF - and I don't use Windows for other things than FAF. So there is a bit of time between each time I'm on the FAF computer ...).


When running from source the stdout is the log. And you can set it to debug level and you will also see all the messages that are being sent between the server and you.


Full logs, loglevel debug. I pressed "Create game" a few times, with not result.


I'm also getting some file not found errors:

java.io.FileNotFoundException: META-INF/native/netty_tcnative_windows_x86_64.dll
java.io.FileNotFoundException: META-INF/native/netty_tcnative_x86_64.dll
java.io.FileNotFoundException: META-INF/native/netty_tcnative.dll

@Sheikah - I was able to narrow down the issue. Are you able to reproduce?

I'm allways getting the failure when the password contains "ø".

Using only english letters in the password does not trigger the error.

I created a github issue: https://github.com/FAForever/downlords-faf-client/issues/2517


Okay that makes sense then. Generally things like these game properties are limited to ASCII. I am surprised it didn't give a more informative error but will make sure to restrict it properly