2 Crashes in 2 games. New patch unstable.

0

java.lang.RuntimeException: Forged Alliance Crashed with exit code -1073740768. See game_15379644.log for more information
at com.faforever.client.game.GameService.lambda$spawnTerminationListener$43(GameService.java:696)
at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1130)
at java.base/java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:630)
at java.base/java.lang.Thread.run(Thread.java:832)

game_15379644.log

game_15379586.log

both logs finished here.

debug: Current gametime: 00:02:30
debug: Loading module '\000/lua/ui/dialogs/keybindings.lua\000'
debug: Loading module '\000/lua/keymap/properkeynames.lua\000'
debug: Loading module '\000/lua/keymap/keynames.lua\000'
debug: Loading module '\000/lua/keymap/keycategories.lua\000'
debug: Loading module '\000/lua/ui/game/diplomacy.lua\000'
debug: Loading module '\000/units/ura0102/ura0102_script.lua\000'

0

3 Crashes.

java.lang.RuntimeException: Forged Alliance Crashed with exit code -1073740768. See game_15379736.log for more information
at com.faforever.client.game.GameService.lambda$spawnTerminationListener$43(GameService.java:696)
at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1130)
at java.base/java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:630)
at java.base/java.lang.Thread.run(Thread.java:832)

0

Yes - we're aware of the issue. Please share the information of the debugger (the window that opens when the game crashes) and share that here. We're onto one hard-crash that we can and will hotfix on Monday.

0

Hi Jip, the debugger gave me the above unless there's a different screen? I shared the dump logs. Looks like it was a CodeCave Malicious attempt flagged by one particular endpoint scanner (Sophos)

0

Looks like it was a CodeCave Malicious attempt flagged by one particular endpoint scanner (Sophos)
A what ?

Can you provide us with more information?

With regard to the debugger - the client at the moment relays the wrong information (the game is, for example, not made in Java). I'm writing up an article about how to get the right information.

0

@Jip There are XACT3DApply errors in both the provided logs. Could this just be an audio issue?

0

I missed those - it could be a combination of the two. Good spot.

@TacticalBacon1st make sure to have stereo sound on. There is a topic about this on the forums, but I can't find it right now.

1

@jip said in 2 Crashes in 2 games. New patch unstable.:

I missed those - it could be a combination of the two. Good spot.

@TacticalBacon1st make sure to have stereo sound on. There is a topic about this on the forums, but I can't find it right now.

https://forum.faforever.com/topic/796/i-can-t-hear-some-of-the-audio-or-other-sound-issue-what-should-i-do

0

Thanks, I'll check it out 🙂