Map editor. My map is blackened when I test it

0

Hello,

I'm trying to create my first water map.

When I want to test it, I have a issue. the bottom of my screen is bugged.
image_2021-08-03_161613.png

I read on the wiki that it is the "black plane" bug. I reduced the height difference between the highest and lowest point so that it is less than 50 (well I hope I did it right, the map editor shows me no more alert message about this when saving) but the problem is still there.
I then tried to raise the map in order to create a deep crater on a corner as it was indicated on the wiki, but still the same result.

since then I have been desperately looking for a solution for hours. I'm trying to figure out what I did wrong, does anyone have any ideas to help me fix this?

Thanks

0

Can you show me a screenshot of your map in the editor? It looks strange regardless of the corner.

0

@jip here is a screenshot where I set a height of 40 maximum on the entire map. on this version the craters in the angles are not present. (I made several versions so as not to break my map during the manipulations) image_2021-08-03_164246.png

0

Can you go to the lighting tab?

0

@jip I haven't changed anything on the light yet. here is a screen :
Sans titre.jpg

0

I don't know then. I can imagine the hills being too sharp, that can cause issues at times. But this specific bug I can not recall having myself before.

edit: does it only happen when you zoom all the way out?

0

@jip
Yes the bug is only present with certain positioning of the camera on the map as well as a certain degree of zoom.

I think the bug is water related. when I remove it from the whole map the bug disappears

I have a friend who is also trying to create his water map and he has the same problems as me

Edit: just to be sure, the map editor names it: fafmapeditor_alpha_v0703?

0

That is the correct version. I can't help you further - maybe @MadMax can.

0

okay np, thanks you !

0

upload the map or send me the file on discord

0

wish i could help i've seen this bug before never been able to fix it tho short of exporting every thing then importing back to a new map

0

does it only happen with this map as it looks suspiciously like a ui mod bug

0

Thanks for your answers,
I will try to export / import the map later.

When I do my tests, I directly use the "test map" button on the editor. Are mods installed from the FAF client activated when I play from the base game?
I only have 2 UI mods active simultaneously, Nvidia fix and Philip Crofts soundtrack or Total Annihilation Music.

0

from 2014 but maybe what you are searching for:
https://forums.faforever.com/viewtopic.php?f=42&t=6361

[...] the maps break (huge black area) when the height range in a map is too large.

0

don't use the test map button in the editor it can cause issues either test through the client or the offline exe found at

C:\ProgramData\FAForever\bin\ForgedAlliance.exe

0

Okay, I won't use the test map again in the future.

I solved my problem. I cut the map into a few parts that I removed one by one until the time to identify the problematic places. I confirm that the problem is related to the heightmap. Somes mountains had to be completely removed and impossible to add new ones to these places without making the bug reappear. It's a bit annoying but at least I'll stop struggling on that xD

Thank you all for your help !