NVIDIA Performance Problem Update - April 2021 - 466.11

1

NVIDIA have released a patch (466.11) to fix the stuttering issues experienced in Supreme Commander:

[Supreme Commander/Supreme Commander 2]: The games experience low FPS. [3231218/3230880]

http://us.download.nvidia.com/Windows/466.11/466.11-win10-win8-win7-release-notes.pdf

After you update to the 466.11 driver you should be able to disable the Nvidia fix mod and re-enable the NVIDIA Display Container LS service if you also disabled that service during your troubleshooting.

We would love to hear from you in this thread if this fixes the problem for you!

However, in my experience I still encounter some issues. I have narrowed it down to my dual monitor setup. Note, I do not play SupCom dual screened but rather I just have my desktop/discord on the second monitor. If I pull the monitor cable out of my second monitor during the game the stuttering disappears. I'd like to hear from other people with multiple monitors to see if they experience similar issues. The easiest way to notice it is to zoom in and out quick and repetitively whilst swinging your mouse cursor rapidly left and right with air units on screen.

Refer here to the original pinned Nvidia driver performance problem thread: https://forum.faforever.com/topic/779/nvidia-driver-performance-problem/

Promotions Councillor

0

Nice sleuth work! I have installed, tested and confirm this works without the "nvidia fix" modification.

Excellent they paid attention to this for such a small audience.

1

I have 3080 card and although i dont play much, i just had a game vs the AI on dual screen and it was unplayable. everytime i moved the mouse the thing jerked all over. Same when i went single screen mode - with my second monitor just windows. I disabled my second monitor from the windows/display setup and then the game runs fine.
I have the latest nvidia driver (466.11) and tried both with and without the nvidia UI fix mod (it made no help to me at all).
Hope this info might help you confirm what you suspect

0

@xsdna Yeah that's the exact issue I face. I'm running GTX 1080 so it seems this problem is experienced over a few different generations of cards as well.

Promotions Councillor

0

@xsdna I have been going back and forth with nvidia since I made this post. They may have come up with something that seems to alleviate the issue.

My main monitor was set to perform scaling on my GPU and my second was set to do it on the Display itself. I have checked the "Override the scaling mode set by games and programs" setting and set the second monitor to scale on the GPU. It appears to have solved the issue. I still get a slightly larger frame drop zooming in/out and moving the mouse frantically - but we're talking a 10 fps drop not a 100+ one.

Can you do the same and confirm this? The setting is in the NVIDIA Control Panel under Display, Adjust desktop size and position and then the scaling tab for all of your monitors.
b65965de-90ed-4b3f-bad9-bdd21e46f7e7-image.png

Promotions Councillor

0

I've done some more testing and this solved multi-monitor issues in a few games including SupCom, Rocket League.

Promotions Councillor

0

Not sure what happened, but even with the latest driver I am now experiencing the issue again. I have not installed any new modifications, altered graphics settings, changed hardware, etc etc....

It’s really awful to the point where it feels like the game is -4 ...

1

I use Dule monitors on a GTX 1050 Ti OC, trying to run it on the latest update's the game starts off fine but it rappidly gets worse and worse till it is unplayable, and the only way i found to get rid of the lag was to compleatly shut down and restart the pc, or the easyer option I found was rolling back the driver to 457.51 witch sadly is old but I have had no lag/shudder issues since.

0

This issue has returned.

@Jip has said

We're going to add the 'Nvidia fix' to the base repository with the next patch 3726 on the 26th of November.

In the mean time you can use the console command or Nvidia fix mod.

Promotions Councillor

0

Once a PR on changing the mounting of the game is finished I'll make a PR that adds what the mod does to the base game, and then blocklist the nvidia mod all together so that it doesn't interfere. At that point it can also be hidden in the vault - but lets first finish that PR this weekend 🙂 .

A work of art is never finished, merely abandoned

0

guys, I don't understand where to download this fix mod, can you give a link?

0

It is in the mod vault, part of the client

A work of art is never finished, merely abandoned

0

@maliboo For now the best thing to do is DDU back to version 472.12
https://www.nvidia.com/en-us/geforce/forums/game-ready-drivers/13/471331/geforce-49613-grd-feedback-thread-released-101221/

[Supreme Command:Forged Alliance/Supreme Commander 2]: Performance drop when there is mouse movement [3405920]

0

Thx, guys

0

@furyritchie said in NVIDIA Performance Problem Update - April 2021 - 466.11:

This issue has returned.

@Jip has said

We're going to add the 'Nvidia fix' to the base repository with the next patch 3726 on the 26th of November.

In the mean time you can use the console command or Nvidia fix mod.

It appears that the console command and mod were not enough to resolve this in my case.

1

go into services in windows and stop service nvidia display container LS service and set it to manual start fixes the issue

0

@el_syd
If you're using multiple monitors then disabling the NVIDIA Display Container LS service will work.

That said if you have multiple monitors but don't use both in game you can check another setting.

  1. Open the NVIDIA Control Panel
  2. Under Display then Adjust desktop size and position
  3. For all monitors set Perform scaling on to GPU and apply the setting.

This fixed issues I had with a number of games.

Promotions Councillor

0

@furyritchie said in NVIDIA Performance Problem Update - April 2021 - 466.11:

@el_syd
If you're using multiple monitors then disabling the NVIDIA Display Container LS service will work.

That said if you have multiple monitors but don't use both in game you can check another setting.

  1. Open the NVIDIA Control Panel
  2. Under Display then Adjust desktop size and position
  3. For all monitors set Perform scaling on to GPU and apply the setting.

This fixed issues I had with a number of games.

I'm afraid that this didn't work for me. Am I supposed to also implement this together with the d3d_windows cursor console command or nVidia fix mod?

0

@el_syd
Yes. You might have to downgrade your video driver until NVIDIA fix it if nothing here works.

Promotions Councillor

0

The "Disable the NVIDIA Display Container LS" worked for me. Was getting sad that the game was getting jittery!