Lost connection to server during login

0

Did you try again? Is this problem still present?

Since you can post here in the forum, you can access our server in general. But I don't see any reason why login should fail 😞

0

@Brutus5000 Yep, I've tried for 2 days to login, but still see this error:(

0

It is possible that you have anti virus or a firewall blocking the client

0

@Sheikah no, I don't have antivirus and turned off a firewall many times.

0

Maybe try the release candidate client. This client version is the one that starts a server on 8080, maybe that is causing some weird interaction. Don't know why it would be but, it might be worth a shot.

from log:

2021-03-14 16:49:21.806  INFO 2524 --- [JavaFX-Launcher] o.s.b.w.embedded.tomcat.TomcatWebServer  : Tomcat started on port(s): 8080 (http) with context path ''
0

@Askaholic client.log
It was on v1.4.3-RC2 client from https://github.com/FAForever/downlords-faf-client/releases/tag/v1.4.3-RC2 Port 8080 is open, firewall and antivirus is off.

0

Try rc3, it has the fix for the tomcat server.

https://github.com/FAForever/downlords-faf-client/releases/tag/v1.4.3-RC3

0

@Askaholic and again... it doesn't work((( Looks like Im cursed( client.log

0

@Sheikah is this normal?

2021-03-17 17:26:22.174 ERROR 3496 --- [JavaFX Application Thread] com.faforever.client.fx.JavaFxUtil       : Uncaught Application Thread Error

java.lang.NullPointerException: Cannot invoke "com.faforever.client.player.Player.equals(Object)" because the return value of "com.faforever.client.teammatchmaking.Party$PartyMember.getPlayer()" is null
	at com.faforever.client.teammatchmaking.TeamMatchmakingService.lambda$initMyParty$30(TeamMatchmakingService.java:367)
0

That happens because the login failed so the current player isn't set. Unfortunately it a symptom of the login failure not a cause.

0

It seems that I have the same problem now after switching ISP recently.
I also tried new pre-release client versions with no luck.
I can login using mobile LTE connection but of course its too unstable and laggy to play with other players.
19b5f3e6-7232-437c-91e2-521dbde5ff4b-image.png

0

That’s so strange because the server it’s connecting to is literally the same server that runs the website and forums and everything else. Are you able to connect to the irc server by chance? irc.faforever.com.

Is it possible that the ISP is doing some sort of port filtering and blocks traffic to 8001 because it doesn’t recognize it? That would seem really weird.

0

@Askaholic I've added this adress into my router's vpn and it still doesn't work( IDK what else can be done in this case...

0

Are you able to connect to the test server? Select the test server from the environment dropdown and use the password foo instead of your normal password. If your username doesn’t work, try using foo for the username as well.

I think the test server is actually a separate machine with a different IP address from the main server.

0

@Askaholic still the same((( I uderstand nothing...

0

Hmm. Are you able to try what sernikb did? Use a mobile hotspot and connect to it with your computer. You wouldn’t want to play like that, but at least it would narrow it down to a network/isp issue and not something with your local setup.

If it’s your ISP blocking certain traffic then the only other thing I can think of atm is using a VPN. I know you said you tried setting your router’s vpn but what if you just try ProtonVPN or something.

0

They could also try the python client to verify it is ISP or not ISP

0

or at least if it is a java specific issue

0

Maybe somebody has a link where to download it, I got no idea