Linux Support

@Cyborg16 did you try having steam generating a run file, copying that file to your FAF folder and having FAF point to that instead?

@tatsu yes that's what I've been doing all along.

@cyborg16 oh you got the niceness level bug. I had that before. I solved it by reinstalling my linux in the newest version.

sorry 😕 no better solution.

I have recently had to format and reinstall Ubuntu 20.04.
Trying to reinstall steam via the .deb already caused some issues with missing 32bit packages.
Rather than going on a hunt for all these packages I just installed the flatpak version of steam instead which seems to work fine.

However trying to launch FA from steam (no matter the ProtonDB version selected and yes I use the recommended launch options) results in a black screen with an error popup that has as the first line:
CD3DDeviceResources::DevResInitResources: Unable to load effect file /effects/cartographic.fx
The rest of the log is exactly the same (except for the filepaths ofcourse) as the reddit link in other examples.

This error is discussed on the linux setup page on the faf wiki, but only in relation to the original ISO setup.

It seems like it has something to do with directx9.
I have already experimented cycling through different Nvidia drivers with no succes.

Do any of you know what this is and if there is a solution?

Some other examples of people with the same Error:

Just a couple days ago on an unknown linux distro:

on the old FAF forums:

In 2010 on Windows:

There also seems to be a slightly different version of this error which apparently can be resolved by pointing the FAF client to the right executable as discussed:
But this version of the error doesn't seem relevant for those that follow tatsu's youtube video and point FAF to the runfile generated by steam.

Does anybody know what the error means and what can be done to fix it?
Because I have for a fact played FA with this exact laptop using ubuntu 20.04 in the past.

Yeah I tried and failed with the flatpack method.

path doesn't go through.

that's probably by design. it's supposed to be a sandbox.

so I just force the .deb install of steam.

it works if you make sure graphics drivers are correctly installed first.

@pa4sam this post, in the reddit thread you linked, helped me:


Hey! I just had this problem and the solution was not obvious. I don't understand the whole complexity of it, but for me it was missing some libraries (notably d3dx9) that are not bundled into proton by default (I imagine because it is so old!).
To fix this I installed proton tricks following this guide ( and then installed the d3dx9 library with the command
"protontricks 9420 dlls d3dx9"
I also needed to run
"protontricks 9420 dlls xact"

This was on a fresh install of Ubuntu 21.04 with nvidia 470 drivers. But i tried absolutely everything (nvidia drivers, different proton, reinstalled steam, even reinstalled Ubuntu, tried every 386 driver i could find etc) in every thread before this and nothing worked. Game crashed on launch. But i could start the game fine after these tricks.

Edit: if you change proton version, you need to redo this, (and maybe recopy the run file)

Edit 2: actually i seem to have no sound at all ingame...

Edit 3: lets give an update. I fixed the sound simply by changing "headphones out" to "line out" in Ubuntu sound settings. Dunno why it worked, i have never had issues before. Maybe something with xact and proton and gnome and pulseaudio... I use old analogue headphones, without USB connectors.

Anyway i found a spare drive and installed manjaro, fresh install steam and forged alliance, and get the same errors. Only installing d3dx9 and xact fixed them. Sample size = 2 but i think those libraries are missing from proton. (I also had the exact same audio problem in manjaro).

@usling I don't know why you're having the sound issue.

seems unrelated to the software at play here.

But I gotta say you're boss because the above is exactly what I needed for my new ubuntu 21.04 with an nvidia graphic card (470 driver) !!!

I would get a full black screen except for the game cursor.

adding PROTON_USE_WINED3D=1 to the steam args

and then running
protontricks 9420 dlls d3dx9
protontricks 9420 dlls xact

fixed it for me

plus I have sound.

it's so weird how when you run ubuntu upgrades you don't have any issues with your games but when you install the new OS version from scratch everything breaks. (and this is despite the fact that I'd be migrating proton version and ect)

I guess it just keeps some old files in the system somewhere that do the trick.

So this is what worked for me with fresh installs on both Ubuntu 21.04 and Manjaro with gnome (aug 13 2021) and nvidia 470 driver:

  • Grab a coup of coffee. Maybe some chill music also.
  • Install steam.
  • Install Supreme commander: forged alliance using steam.
  • Enable steam play (steam -> settings -> steam play -> "enable steam play for all other titles" and i set it to Proton 6.3-5
  • Launch options: In steam library, right click Supreme commander: Forged alliance -> Properties...
    Then under "General" -> "Launch options", put PROTON_NO_ESYNC=1, PROTON_DUMP_DEBUG_COMMANDS=1 %command% /windowed 1024 758
    Under "Compatibility" check "Force the use of a specific Steam Play compatibility tool" and choose whatever Proton version you think is best. I went with 6.3 but some ppl say 5.0 is better.

You can try to run the game now, it crashes on launch for me, saying
"CD3DDeviceResources::DevResInitResources: Unable to load effect file /effects/cartographic.fx"

If game runs fine, skip the next section and just edit game.prefs (last step)
If you get that error, close the game and let's fix it.

  • Install winetricks (it will probably also install some dependencies and wine itself)
    ubuntu: sudo apt install winetricks
    manjaro: sudo pacman -S winetricks

  • Install protontricks using this guide:

  • in a terminal, write protontricks 9420 dlls d3dx9

  • in a terminal, write protontricks 9420 dlls xact
    (if you, at a later stage, change proton version in steam, you have to reinstall the above two libraries since they don't seem to come with proton.)

Now start the game. It should start. Create a game profile ingame and exit.

  • edit your Game.prefs
    on ubuntu it's located in:
    ~/.steam/debian-installation/steamapps/compatdata/9420/pfx/drive_c/users/steamuser/Local Settings/Application Data/Gas Powered Games/Supreme Commander Forged Alliance/
    primary_adapter = '1024,758,60',
    to whatever your native screen resolution is, mine is:
    primary_adapter = '2560,1440,60',
    and save.
  • Edit launch options again (see step above) and remove /windowed 1024 758 leaving just PROTON_NO_ESYNC=1, PROTON_DUMP_DEBUG_COMMANDS=1 %command%.

Rune game again and try skirmish.

If you use analogue headphones and have no sound, try change sound output in ubuntu/manjaro gnome from "headphones" to "line out". I've never had any issues with this before, must be some Wine edge case.

You can use my script. Can be fed to the client no problem and used to run faf games.

This will be integrated into the client in the future (tm)
You'll need to set your game location on it etc

My God . can simple steps to install faf and play. to make it just work ...

@yarikchi Doesn't my script work for you (In a few DE's it weirdly doesn't)? I tried to simplify it as much as possible.

@usling it worked for me as well! 😄

After messing around a bit more, I still can't seem to get rid of the issue where the game will jitter/get stuck on a frame for a bit (but noticably) longer than all the other frames. In other words, the game mostly flows at the right frame rate, with quasi regular frame lag every couple of seconds or so. Any suggestions? Thanks!

на 32 бита нет версии?

@esthetics of what? I don't know what you're talking about. FA is 32bit.

Hi everyone.

I got few monthes ago a new computer which is best suited to play SupComm : FA.

I installed Steam on my new computer and have no problem to run forged alliance from steam.
But i can't launch a game or a replay from FAF.
I installed FAF and even try the last version recently (1.6). Faf run without any problems, but when i launch a game from the program, i get an error :

java.lang.RuntimeException: Forged Alliance Crashed with exit code 2. See  for more information
	at$$Lambda$2943/ Source)
	at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
	at java.base/java.util.concurrent.ThreadPoolExecutor$ Source)
	at java.base/ Source)

My skills are limited, and i can't find a way to fix that problem.
I was wondering if it's because i installed the Flatpak Steam on my linux mint, instead of the regular one. Anyone use flatpak version of steam ?

Did you launch the steam version and make a profile before launching FAF?

A work of art is never finished, merely abandoned

Yes sir. 🙂
And copy the "run" file in the good folder.
I changed de path to be the one used by the flatpak version of steam. But maybe i forgot something ?

If you want to see some logs, just tell me which one and how to get it 🙂

Thanx for your help 😃

@zorglub yes it is indeed because you installed the flatpack version of steam. I recommend you delete that and any leftover steam files

(do not attempt to have a flatpak steam simultaneously with a native steam that is a terrible idea)

if you want to avoid redownloding the games you downloaded, you can take the folder in : steam called "common" that is under "steamapps" (if you right-click on the game in the steam library you can open the folder where the game is installed, then by going up one folder you'll have the "common" folder.) you can move that folder to another place, (say Documents) and then delete steam flatpak and install steam as a native.

when you are here : it gives you the right file.

you can run it by right clicking in empty space in the folder you downloaded steam to then selecting "open in terminal" and in the window that pops up, type in :
(I'm assuming you're on Pop_OS, ubuntu, mint, kubuntu, Zorin,... basically debian based. if not and you're on Manjaro or something like that, you'll have to do something else like sudo pacman -S steam )

sudo dpkg -i steam_latest.deb

(you'll need to type in your password)

then follow the steps and then you'll be able to run steam from your start menu.
make sure to enable proton for all games in the options (steam was completely reinstalled so you need to do everything again)

then you can close steam, move your "common" folder to :

then start steam back up and start the download for the games you previously had installed.

steam will recognize the games are already in the right folder and simply "discover" them instead and then they'll be installed.

then you can try again by giving steam the run arguments I talk about in my video
run FA once from steam, go fetch the run file and put it in your FAF install dir and point to that in the FAF options.

and you should be good to go.

Great, you confirm my suspicion.

i'll try what you suggest when I got some time (i'll need to move other games too) 😃