Cant start FAF

0

Hi guys, iam new to this. I downloaded FAF, tried to install the FAF client and connected it with my steam account but i cant start the game.

I get the following message:
"In order to play on FAForever, we need to verify that you own a legal copy of Supreme Commander Forged Alliance. You can verify ownership on the website at
https://www.faforever.com/account/link"

After i click on the link, the following website opens on which is stated "And you are done with Steam link forever!".

What should i do next?

I am a bit lost now.

thanks in advance!

0

Are you able to download and install the “FAF Client” which you find on Faforever.com?

If so, then you should be able to launch a game by starting the client, logging in, then on the tab “Play” you can do a custom game vs the AI by clicking “Create Game”.

With the CD-ROM version (not Steam version), if I remember correctly, one had to do one extra step the first time, namely create a profile inside the game. (This may or may not be the same for the Steam version.) I did so by launching the game through the .exe file of the actual game (not of the FAF client), then inside the game create a profile name. Then you’d exit the game and launch the FAF Client, set up a FAF profile, and from then on you’ll always launch the game through the FAF Client. Does that work for you?

0

thanks, it works now!