I can't open the custom campaign map in SupCom Map Editor!

0

I tried to create a campaign in FAF Map Editor, but I encountered a problem - I can't control cameras normally in FAF Map Editor. I tried installing the SupCom Map Editor by following the instructions on the FAF Wiki. I open my map using the SupCom Map Editor, and after a few seconds the SupCom Map Editor crashes.
I can't control cameras normally in FAF Map Editor, and i need to open my map in SupCom Map Editor to edit the cameras normally.
Please help me open this map using the SupCom Map Editor.
This is a link to my campaign map.
P.S.: Sorry for my bad English - I'm from Russia and I translated through the translator program.

0

I think your real problem is why you cannot control the camera in the Ozone editor.

But, next to that, make sure that:

  • You save the map in the Ozone editor as v56, instead of v60 (Map -> Scenario -> Other)
  • The scenario files of campaign maps are incomplete. It needs some additional fields or the old GPG editor crashes. I believe these to be the no-rush offsets that are present in other scenario files, but I am not too confident on that. I believe @Speed2 knows more about that.

As mentioned below, an army with color '20' is out of range for the old GPG editor, turning that to 0 solves the issue. They can be found in the _save.lua files.

0

I was able to solve the problem-In the _save.lua file I put the colors of all the armies on 0. This helped and the map opened.
It is possible that the program could not find the color for some armies before the fixes, because the color number for some armies might not be occupied.

0

Yes, the only problem was one army with color 20, that high number doesnt exist in vanilla colour files so the editor crashes

Log in to reply