Stuck on 'Connecting...' screen when joining game

I can't join the lobby for a game, and get stuck on the 'Connecting...' screen.


  • I recently had to do a Windows 11 OS reinstall (corrupted OS), and so have reinstalled SupCom FA, and the FAF client. I also started FA once, so it sets up game files, etc.
  • I've tried 'Force Relay Connection' both on and off.
  • When viewing the 'FAF ICE Adapter - Debugger' window, other players' "state" cycles between 'disconnected' and 'checking'
  • I deleted McAfee.
  • I temporarily disabled the windows firewall to see if that made any difference. It did not.
  • I restarted by router, and I don't have any port forwarding or specific blocking rules set up.

It used to work perfectly fine before the Windows OS 11 resinstall, and also wierdly, I WAS able to connect to 2-3 games (out of about 40 tries), and I am able to create my own game instance in the faf client -- but haven't checked if other players can join.

Any ideas on how to troubleshoot why I'm getting this? What clues are there in the log files that indicate why it's getting stuck?

Disabling IPv6 fixed it.