Game Crash on "Create Game" Linux


When I create a custom game the launcher tries to start the game. But it crashes before opening 😞 I am on 5.10.68-1-MANJARO. Can you help me please?

I tried the release 1.6:


and 1.6Beta1:



Hi. I have no idea about linux but your game log shows:
"warning: Can't open lua file "Z:\home%USER%.faforever\bin..\Installed.Prefs"
warning: unable to load Installed.Prefs; using empty initial prefs"

so it seems you dont have a game.prefs file
Did you start the game once from steam?
If not, do so to create a game.prefs file (which safes your personal settings like resolution, hotkeys, templates and os on) and then try again on FAF


Sounds like a problem with wine. How are you running the game? From my experience proton 6.3 works pretty well, and it should be consistent across distros since it uses containers.


@amygdala Thank you for the reply, I did start the game before to create a profile. I started it once more to no avail.

@MazorNoob Thanks for the reassurance, wine is what I understand the least. I am using proton 6.3 from steam and installed wine, wine-mono, winetricks, protontricks 9420 dlls d3dx9 and protontricks 9420 dlls xact. Steam is not a flatpack.

I played two games some weeks ago under 1.4.7 with the lutris installer until it stopped working.

I reinstalled it with the help of tagedas video.
I had to use jdk15-adoptopenjdk

I launch the client with:

export INSTALL4J_JAVA_HOME=/usr/lib/jvm/java-15-adoptopenjdk/

I will try reinstalling wine now.

Reinstalling wine wasn't enough. I will try reinstalling everything tomorrow but first I need some sleep.


I'd avoid installing stuff with winetricks unless you verified things don't work without it, sometimes overrides can make things worse. Try this:

  • Remove FA's wineprefix.
  • Run FA once through Steam to verify it runs and install whatever deps Steam usually adds. In case of issues use protondb, only use winetricks as a last resort.
  • Set launch command in FAF client as needed.


Thank you very much it works!
I removed FA's wineprefix from the location stated in the run file. Afterwards I uninstalled supcom from steam and removed wine, wine-mono and winetricks. I also removed everything from the FAF client, including the hidden files in ~/

I followed the guide from @Usling
and did not have to install winetricks or wine itself manually for supcom to start under Proton 6.3-7.

Afterwards I followed the guide from the wiki.

Last time I forgot to set the launch command in the FAF client, so that was a good hint of you and probably the reason why it did not work in the first place. I think that step is missing in tatsu's video or I missed it.

I am looking forward to play with you guys 😄


Hi All, I'm getting the errors below with my new/clean install.
Ubuntu 20.04: Steam: Proton: SupCom + FA: FA is tested and working like a dream.
FAF Java Client
Java-15-oracle is now Java-17-oracle; 15 has been removed as it is end of life.
I had to edit faf-client and replace 15 with 17 in two places; FAF-client is working and I'm logged in.

Click on a map and create game, create; I get the following errors;

java.util.UnknownFormatConversionException: Conversion = ' '
at java.base/java.util.Formatter.parse(
at java.base/java.util.Formatter.format(
at java.base/java.util.Formatter.format(
at java.base/java.lang.String.format(
at com.faforever.client.fa.ForgedAllianceService.startGameOnline(
at java.base/java.util.concurrent.CompletableFuture$UniApply.tryFire(
at java.base/java.util.concurrent.CompletableFuture.postComplete(
at java.base/java.util.concurrent.CompletableFuture.complete(
at java.base/

I suspect this is Java-17-oracle related but any help would be appreciated.


Its not Java-17 related.

I think it fails because your launch command ("Command line format for executable" in settings) is missing %s (this part of the string will be replaced with the .exe location when starting a game).


Thanks Katharsas.

I've changed that field to blank was "PROTON_NO_ESYNC=1 PROTON_NO_FSYNC=1 %command% /windowed 1920 1080"
but still failing to launch FA.

See the log here;
2021-11-13 16:38:48.491 INFO 51127 --- [lication Thread] com.faforever.client.update.Version : fromVersion '1.4.6' is not newer than toVersion '2021.11-alpha-4'. No update is required.
2021-11-13 16:38:48.519 INFO 51127 --- [lication Thread] com.faforever.client.user.UserService : Logging in with refresh token
2021-11-13 16:38:48.916 INFO 51127 --- [tor-tcp-epoll-2] com.faforever.commons.lobby.FafLobbyApi : Connected to on port 8002
2021-11-13 16:38:50.870 INFO 51127 --- [lication Thread] com.faforever.client.update.Version : fromVersion '2021.10' is not newer than toVersion '2021.11-alpha-4'. No update is required.
2021-11-13 16:39:05.335 INFO 51127 --- [pool-3-thread-3] c.f.c.patch.GameBinariesUpdateTaskImpl : Updating binaries to 3724
2021-11-13 16:39:05.415 INFO 51127 --- [ Thread-41] : Starting ICE adapter with command: [/usr/lib/jvm/java-17-oracle/bin/java, -jar, %USER_PROFILE%/Games/faf-client-2021.11.0-alpha4/natives/faf-ice-adapter.jar, --id, 260187, --login, Zarrex, --rpc-port, 59093, --gpgnet-port, 8879]
2021-11-13 16:39:05.731 INFO 51127 --- [ Thread-41] c.f.client.fa.ForgedAllianceService : Starting Forged Alliance with command: [%USER_PROFILE%/.faforever/bin/ForgedAlliance.exe, /init, init.lua, /nobugreport, /log, %USER_PROFILE%/.faforever/logs/game_15710019.log, /gpgnet,, /mean, 1500.0, /deviation, 500.0, /savereplay, gpgnet://, /country, GB, /numgames, 0, /numgames, 0] in directory: %USER_PROFILE%/.steam/steam/steamapps/common/Supreme Commander Forged Alliance/bin
/home/andyh/.faforever/bin/ForgedAlliance.exe: 1: MZ����@0��: not found
/home/andyh/.faforever/bin/ForgedAlliance.exe: 1: Syntax error: word unexpected (expecting ")")
2021-11-13 16:39:05.733 INFO 51127 --- [onPool-worker-6] : Forged Alliance terminated with exit code 2
2021-11-13 16:39:05.753 WARN 51127 --- [tor-tcp-epoll-2] : Ignoring call to ICE adapter as we are not connected: setIceServers([[{credentialType=token, urls=[,,], credential=cjzETqLAtXQs2l/KeckOmCGSnp4=, username=1636907945:260187}, {credentialType=token, urls=[,,], credential=cjzETqLAtXQs2l/KeckOmCGSnp4=, username=1636907945:260187}, {credentialType=token, urls=[,,], credential=XK0B5Sykd4Q9/7GHfRr5Jtmeamw=, username=1636907945:260187}]])

In FAF-Clinet, Settings, Forged Alliance Forever I have;
Game Location: /home/{UserID}/.steam/steam/steamapps/common/Supreme Commander Forged Alliance
Command line Format for Exe: %s / Blank
Exe Directory: /home/{UserID}/.steam/steam/steamapps/common/Supreme Commander Forged Alliance/bin
Automatic Map download: Enabled


Try inserting path to wine executable between PROTON_NO_FSYNC and %command%.


That’s the wrong command. You need to change the one in the client settings to "%s" not the one in the steam settings



Thank you, however I'm not using WINE. Steam only (with Proton).


Proton is just wine plus some extra stuff, so yea you are using it.



Thank you; I have tried 'blank' and "%s" neither worked.
Just retried, to be sure, and no neither worked.
"Exit code 2"


Thanks for the correction. I thought Proton was Steam/Value's API that could work with WINE, not that it was an extension of it.
Do I need to install wine ? Typing # wine or # wine --help certainly confirms that WINE is not installed.


@Zarrex can you post screenshots of your launch command settings from the FAF client and steam?


All of is kind of confusing for me, there is exactly one location where %s works, which is inside the FAF client settings under "Command line format for executable".

When the client starts the game, it will replace %s with the path to the FA executable. You can modifiy the command so the client adds additional parameters, for example %s /nosound should start the game with /nosound parameter. I have no idea what %command% is so i cannot help with that.

Then there is this part of your log:

/home/andyh/.faforever/bin/ForgedAlliance.exe: 1: MZ����@0��: not found
/home/andyh/.faforever/bin/ForgedAlliance.exe: 1: Syntax error: word unexpected (expecting ")")

Is this really what is inside the log? Its better to post the log as file attachment so we know if this is a forum problem with encoding or if that is actually in the log. Btw the forum uses markdown, so you can use backticks ` to make it clearer when you cite a value.