Map editor issue

0

I made a cool map using the map editor, but when I load in it instantly says "you were defeated" and the game ends. Any ideas?

0

@cerulium Map not cool enough. Try again.

But seriously:
Did you add start positions? Does your ACU spawn in? Did you copy a game script from another map that has different win conditions?

0

@kalethequick

When I opened the map editor there were already 6 ACU markers in a circle and I just moved those to the positions I wanted them in

0

Also my ACU doesn't spawn in. When I have an AI it instantly says I was defeated and when I load the game with just me it just shows the map and does nothing but I can still spawn in units weth cheats. I didn't copy any game scripts from other maps

0

@cerulium Try making another map with just what's there to start, then seeing if that works. Then look at another map that works, like Finn's Revenge, and see if you can find out how that one works.

0

@kalethequick

Unfortunately I can't find a solution. I loaded up some other maps and they seemed to have it the same way I already did. I tried deleting the army spawn points and placing blank markers and renaming them to army which changed the look of the icon like the wiki said but it still didn't work 😞

0

@cerulium
If your map's files don't include the following code, you may want to adjust/add it (you can edit the LUA files using a free editor such as Notepad++):
Script file:
ec48f408-dcc6-4234-a621-9cbd00aeb3f5-image.png
Save file:
49dc7a77-96c0-44d7-b241-6a0911263039-image.png
There will be other code as well, and the size of the above rectangle should be the size of your map (512 for 10km, 1024 for 20 km, etc).

If you have the above info inputted properly and it still doesn't work, you could look at your map's scenario file and compare it to other maps' scenario files, and try adjusting it to match sensibly.

If you still can't get it to work, you could send your map's files on the FAF discord in mapping-general (you can opt-in to the 'mapper' role that reveals this channel in the FAF discord's role-selection channel), and I can try to solve the problem.

1

@emperor_penguin

I copied a script lua file from another map, pasted it in, renamed it and it worked. I sincerely thank you and @KaletheQuick for reaching out and helping me fix the map