problem while hosting/joining a game

0

it seems like a java isue.
see code below

java.util.concurrent.CompletionException: java.net.SocketException: Permission denied: listen
at java.base/java.util.concurrent.CompletableFuture.encodeThrowable(CompletableFuture.java:331)
at java.base/java.util.concurrent.CompletableFuture.completeThrowable(CompletableFuture.java:346)
at java.base/java.util.concurrent.CompletableFuture$UniCompose.tryFire(CompletableFuture.java:1137)
at java.base/java.util.concurrent.CompletableFuture.postComplete(CompletableFuture.java:506)
at java.base/java.util.concurrent.CompletableFuture.completeExceptionally(CompletableFuture.java:2152)
at com.faforever.client.replay.ReplayServerImpl.lambda$start$2(ReplayServerImpl.java:109)
at java.base/java.lang.Thread.run(Thread.java:832)
Caused by: java.net.SocketException: Permission denied: listen
at java.base/sun.nio.ch.Net.listen(Native Method)
at java.base/sun.nio.ch.NioSocketImpl.listen(NioSocketImpl.java:658)
at java.base/java.net.ServerSocket.bind(ServerSocket.java:397)
at java.base/java.net.ServerSocket.<init>(ServerSocket.java:282)
at java.base/java.net.ServerSocket.<init>(ServerSocket.java:173)
at com.faforever.client.replay.ReplayServerImpl.lambda$start$2(ReplayServerImpl.java:92)
... 1 more

0

I would check your firewall and anti-virus it seems like something is not allowing the client to open a socket

0

Not ideal, but it says permission denied. If you the run the program as "administrator", then that has the highest level of permissions and at least will rule out permissions thing, other than that Sheikah is probably right. You could try turning off your firewall/antivirus as a test. Most antivirus has the option to disable it until the next restart, so give that a try. Could also be a firewall issue, so you can always try to temporarily disable that. If it is that, then you can add a firewall exception. If you have any issues with this, let us know and I can always talk you through it.

0

hi,i did the admin thing,and it seems to be working ok now,also in normal mode.
thx for the help. 🙂