Teams not working

I've just reinstalled the game on a new system and I cannot get the teams set in the lobby to stick. All players are enemies after the game is loaded making it impossible to do a 1 vs 3 AIx or to play with my friends. (Also, one AI mod wont fix AI markers on maps after loaded when I tell it to in the lobby.)

I've tried with and without added mods, with and without human players, nothing I've tried works. At least one friend of mine have the same problem though she's never hosted before so not sure if this is something new to her. Another friend who tested the latest FAF client have no problem hosting with teams even though we have the same settings+client version.

FA standalone singleplayer skirmish works with teams so something FAF doesn't load.

Anyone who knows right off the bat what it is or have a solution?

That issue can happen when a map has certain improper code associated with it. So, you could try testing on a different map that definitely works (such as the regular version of Seton's Clutch (scmp_009)).

If that doesn't work, you could also try reinstalling the game.

If that doesn't work either, you could share a log file from your game session so that we can evaluate that (the upper left corner of the FAF client has a button that you can click that opens a drop-down menu in which there is a 'show log folder' option).

Also, are you able to join/play in other people's team game lobbies on FAF without issue?

pfp credit to gieb