Game Not Loading v1.2.0

0

Hey, I have had the same issue, got it for the first time when I installed 1.1.9 and then it went away again when I went back to 1.1.8, and now when updating to 1.2.0 it still happens. Going back to 1.1.8 it works fine though. Windows 10 64 bit here as well.

Tried deleting the client.prefs file now after updating again but still doesn't work. For me it does not stall on the downlords splash screen though, it just shows it for a second or two and then goes away. Same with the downlords-faf-client.exe process. Going back to 1.1.8 it works again.

0

Well I can not investigate this without logs or profiling it. Or a way to reproduce it

0

So btw what changed from 1.1.8 to 1.1.9 is the java version from 11 to 14. That is likely the issue here. Anyways unless some of you helps us find out why this happens it is gonna stay like that.

0

I changed from 1.1.9 to 1.2.0 and have the same issue, tried all above solutions. The error log says the following:

Exception in thread "WindowsNativeRunloopThread" java.lang.NoSuchMethodError: <init>
at com.sun.glass.ui.win.WinApplication.staticScreen_getScreens(Native Method)
at com.sun.glass.ui.Screen.initScreens(Screen.java:412)
at com.sun.glass.ui.Application.lambda$run$1(Application.java:152)
at com.sun.glass.ui.win.WinApplication._runLoop(Native Method)
at com.sun.glass.ui.win.WinApplication.lambda$runLoop$3(WinApplication.java:174)
at java.base/java.lang.Thread.run(Thread.java:832)
Exception in thread "JavaFX Application Thread" java.lang.NullPointerException
at com.sun.prism.d3d.D3DPipeline.getAdapterOrdinal(D3DPipeline.java:205)
at com.sun.javafx.tk.quantum.QuantumToolkit.assignScreensAdapters(QuantumToolkit.java:695)
at com.sun.javafx.tk.quantum.QuantumToolkit.runToolkit(QuantumToolkit.java:313)
at com.sun.javafx.tk.quantum.QuantumToolkit.lambda$startup$10(QuantumToolkit.java:258)
at com.sun.glass.ui.Application.lambda$run$1(Application.java:153)
at com.sun.glass.ui.win.WinApplication._runLoop(Native Method)
at com.sun.glass.ui.win.WinApplication.lambda$runLoop$3(WinApplication.java:174)
at java.base/java.lang.Thread.run(Thread.java:832)

Any help is welcome!

0

After succesively deleting everything Java SDK related from Windows (including the enviroment variables), reinstalling and restarting Windows it finally worked (following the advice given on a website that deals with an error that is related to this problem):

https://bugs.openjdk.java.net/browse/JDK-8231015

"CUSTOMER SUBMITTED WORKAROUND :
Uninstall other JDKs in the system. It seems removing the jdk 8 from the PATH env variable solves this."

0

Hmm I wonder if we could do something against that... Maybe the installer could modify the PATH variable before launch... Have you got an idea on how to reproduce? If I wanna work against it with the installer I got to reproduce it first. What java version? What was on the PATH? @graftod666

I probably need some help of ppl that have the issue.

0

if I would only find the posts of all the other ppl having this issue

0

I tried installing java jre 8 in the latest version. That did not reproduce it, also tried adopt openjdk 8 and set both PATH and JAVA_HOME

0

Also adding the parameter from the first answer there might help but hard to tell without anybody willing to try or a way to reproduce https://stackoverflow.com/questions/52906570/javafx-11-using-maven-throws-exception-windowsnativerunloopthread

1

Concerning that if you want to test it you need to add the following line

-Djava.library.path=C:/

to the downlords-faf-client.vmoptions in the installation directory. To edit it you need to be an admin. Therefore you need to search for notpad, right click it and open as admin. If opened select File->Open-> Open downlords-faf-client.vmoptions (you might select All Files in the bottom right to be able to see the file) . Add the line at the end of the file and save. Start the client.

0

@axel12 Sorry, i unfortunately haven't documented my enviroment variables before deleting... What i do know though is, that i had the following installed:
Java 8 Update 161 (64-bit)
Java 8 Update 191 (64-bit)
Java 8 SE Development Kit 8 Update 191 (64-bit)

And i had some JDBC entries in my enviroment that i deleted.

probably all not helpfull, sorry...

0

Have not tried Oracle jdk yet only jre

0

@axel12 said in Game Not Loading v1.2.0:

Concerning that if you want to test it you need to add the following line

-Djava.library.path=C:/

to the downlords-faf-client.vmoptions in the installation directory. To edit it you need to be an admin. Therefore you need to search for notpad, right click it and open as admin. If opened select File->Open-> Open downlords-faf-client.vmoptions (you might select All Files in the bottom right to be able to see the file) . Add the line at the end of the file and save. Start the client.

Gave this a go and it worked for me, able to launch 1.2.0 now.

The new UI changes look really good from what I can see so far btw!

0

@Jenstad , this sound wondeful we can include this. if anybody else can confirm that adding -Djava.library.path=C:/
works we can include it by default

0

@Jenstad would u do me a favor and try the following installer after you removed the libary.path fix and see if that installer works. I basically also adds this lib path workaround but by default. And anybody else that has this issue

https://github.com/FAForever/downlords-faf-client/releases/tag/v1.2.1-RC3

0

@axel12 Removed the fix from 1.2.0 and installed the fixed installer, still works, so looks like that solves the issue for me at least.

4f6d6b2f-d186-452e-869b-be1909ecad56-image.png

Log in to reply