4K and huge cursor

0

I got a new laptop with a 4k screen. My problem is that the game cursor is absolutely huge. I understand why this is; I changed the "Scale and layout" to 250%, so I can actually see my windows desktop. Changing the scaling means the cursor scales, whilst the game itself sets it to a sensible resolution.

I have tried changing the ""Compatibility mode" > "Change High DPI settings" for the following programs:

C:\Program Files\Downlord's FAF Client\downlords-faf-client.exe
C:\Program Files (x86)\Steam\steamapps\common\Supreme Commander Forged Alliance\bin\SupremeCommander.exe

.... which makes the cursor look better if I open up SupremeCommander.exe directly, but opening it through FAF must run another program to start SC with FAF and the cursor remains huge. I know I could change my screen resolution or disable scaling but I would rather not have to do that whenever I want to play the game.

Any ideas? Many thanks in advance.

0

C:\ProgramData\FAForever\bin\ForgedAlliance.exe

0

Thank you. There is an installation there but... i dont think that is the one that FAF is using. When i checked in the FAF settings I get the link to:

C:\Program Files (x86)\Steam\steamapps\common\Supreme Commander Forged Alliance\

I changed the compatibility settings on both and when I click on the ForgedAlliance.exe both games run with the correct cursor but not in FAF.

0

I started FAF and checked the program location. You were correct. The program is in:

C:\ProgramData\FAForever\bin

I still have the problem, that despite changing the compatibility settings they are not changed when running from FAF 😞

0

A further update:

I changed the compatibility settings and it works fine the first time but then goes back to its old way 😕 I have realised that Forged Alliance iteself changes the compatibility settings in the registry. I disabled the Program Compatibility Assistant but the settings still keep changing after each game. I wrote this registry change that will fix the huge cursor but it needs to be run each time, before the Supreme Commander.exe is loaded. Not sure if there's an easier way around this but at least its a quick fix.

If anyone wants to recreate this, copy the text below and save it in Notepad. Call the file "FAF.reg" and save it. Opening it will change the DPI settings to stop the cursor being huge!

Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows NT\CurrentVersion\AppCompatFlags\Layers]
"C:\ProgramData\FAForever\bin\ForgedAlliance.exe"="~ DPIUNAWARE"
"C:\Program Files (x86)\Steam\steamapps\common\Supreme Commander Forged Alliance\bin\SupremeCommander.exe"="~ DPIUNAWARE"