My FAF keeps giving me this code, Any advice/help.

@diobolical Can you please click the Reply button at the bottom between the 👁 (View) icon & the "Mark unread" button. Next, please go to client > top left menu > Show logs folder > logs > sort by Date Modified. From there, drag/drop your client.log file (the Text Document file without the date) & the most recent game_22xxxxxx.log file (should be of the last game that crashed) into the Reply message window so those that can help (not me) have that data to look at.

The game log file didnt seem to exist in my folder.

@diobolical Does your vanilla SCFA (Steam, GOG, CD/DVD) work?

it doesnt seem to open when I try to hit play on steam, ive tried to verify integrity, uninstall and reinstall.

@diobolical Go to FAF client > top left menu > Settings > General > Disable Starting with Steam > ✔ > close FAF Client > check Task Manager to verify it closes (may take a minute to complete background logging task) > start SCFA from Steam.

One other thought.. Do you happen to have Citrix software installed on your PC?

I dont know what citrix software is so I doubt so but i will double check

I did as you said and tried to start SCFA through steam and it didnt work

@diobolical OK, 2 things to do for further troubleshooting:

  1. Go to your Steam SCFA folder > DirectX, then run the DXSETUP.exe installer to re-install the DirectX files that SCFA uses (just in case those weren't installed correctly).
  2. Go to Steam > Library > right-click SCFA > Properties > General > Launch Options > copy/paste this into that field:

/log "A:\SteamLibrary\steamapps\common\Supreme Commander Forged Alliance\logs\steamfa.log"

I grabbed that file path from your client.log, so you'll need to change it if that's not the correct path to your Steam SCFA install.

Try Steam SCFA again after doing the above.