Problems connecting FAF game lobbies

I have issues connecting to the game lobby. Restarting my machine normally fixes it (at least temporarily). Any idea what could be causing it? Below is the last part of the log. I think the game might be confused as I have multiple networks attached to my PC. I run VMware machines for development. I notice it sets the NAT handler twice.

info: /country
info: /init
info: /numgames
info: /mean
info: /clan
info: /deviation
info: GPGNET: setting nat handler to 0x11837004
info: LOBBY: Game port 48073[UDP] opened.
info: LOBBY: starting with local uid of 263413 [YouTheNoob]
info: GPGNET: entering lobby state.
info: NET: using deflate compression for sends to %CPU_NAME%:61193.
info: LOBBY: Connecting to host "NotInsanity" [%CPU_NAME%:61193, uid=373906]
info: Can't add chat text -- no chat display
info: text=Connecting to game host...
info: Minimized true
info: Minimized false
info: GPGNET: setting nat handler to 0x00000000
info: CNetTCPBuf::Read(): recv() failed: WSAEINTR
info: Run time: 0h00m49s

If you are looking at this in the future, I figured out what the problem was. I have dual stack: IPv4 and IPv6. I think that the system was switching between IP versions, causing the NAT to fail. I disabled IPv6 on the network interface and it seems to have fixed it.