Unable to upload any map since today (worked before)

I had uploaded maps before without any problem. Since today it does not work and I get that error from the server:

alt text


Having the exact same issue. Anyone know how to fix this?

I think some Server Admin has to look into this.

@Sheikah and I investigated this. The last client release contained a newer library which caused this issue. Updating our dependencies will fix this.

We'll probably release an intermediate release candidate that you can use. Since only map upload is broken, we're not going to do a full release at this causes thousands of players to download the whole 130mb installer.

"Nerds have a really complicated relationship with change: Change is awesome when WE'RE the ones doing it. As soon as change is coming from outside of us it becomes untrustworthy and it threatens what we think of is the familiar."
ā€“ Benno Rice

Thank you very much for the fix and invested time.

You can install this version of the client and it should work https://github.com/FAForever/downlords-faf-client/releases/tag/v1.2.4-RC1

Can confirm - release 1.2.4 fixed it.