AI, defense structures & build templates

0

Hi there,

I just reinstalled everything from scratch (using steam version) and installed Downlords FAF client. So far so good. But when I play against AI (regardless if its sorian or usevo), the AI is barely or not at all building any defense structures.
Also, it seems the template build function is broken. I cannot add any build templates anymore

I then switched back to original steam version, tried the same map, reinstalled the Sorian Mod and voilá, in the original game its working fine.

I then tried total Mayhem mod (for both scenarios), still the same behaviour, except in Steam, even with Total Mayhem (which is btw. awesome!) the AI is doing fine.

As I didn´t find any similiar threads to this topic I can only assume I did something wrong. Anyone out there having an idea, whats wrong with my Forged Alliance?

Thx & Cheers,
Dick

0

Hey Dick, i cant help u with that, but you can play with us in MP.
FAF discord https://discord.gg/redN8TD

EDC epic discord
https://discord.gg/MuPNDT66DY

1

Sorian for vanilla is quite a bit different than the version in FAF. There have been a lot of hands on it, at various points over it's history in FAF, in attempts to 'improve' it and also to make it compatible with some of the gameplay changes in FAF (like Support factories). Some of those changes have impacted fundamental relationships between defense building versus other things.

Your mention of the template function being broken does however indicate that you have a deeper issue, that perhaps only your GAME.LOG can reveal.

0

@herzer99 Thx for the kind invite! I already have some friends and we try to get it up and running to play coop agains AI. 🙂

0

@Sprouto said in AI, defense structures & build templates:

Sorian for vanilla is quite a bit different than the version in FAF. There have been a lot of hands on it, at various points over it's history in FAF, in attempts to 'improve' it and also to make it compatible with some of the gameplay changes in FAF (like Support factories). Some of those changes have impacted fundamental relationships between defense building versus other things.

Your mention of the template function being broken does however indicate that you have a deeper issue, that perhaps only your GAME.LOG can reveal.

Thx for your response Sprouto!
I looked into the game.log and indeed found an error:

warning: Error running '/lua/ui/game/gamemain.lua:OnSelectionChanged': ...orever\gamedata\lua.nx2\lua\ui\game\construction.lua(2676): bad argument #1 to `gsub' (string expected, got boolean)
         stack traceback:
         	[C]: in function `gsub'
         	...orever\gamedata\lua.nx2\lua\ui\game\construction.lua(2676): in function `ConvertID'
         	...orever\gamedata\lua.nx2\lua\ui\game\construction.lua(2702): in function `OnSelection'
         	...\faforever\gamedata\lua.nx2\lua\ui\game\gamemain.lua(545): in function <...\faforever\gamedata\lua.nx2\lua\ui\game\gamemain.lua:484>

I guess this happens when I try to either load or save the template.
One odd thing I experienced was, that my templates I created with the original game are still displayed (when using engineers), but when adding additional ones within FAF only my Commander can see them, not my engis.
Thats happening regardless if I execute it with or without any mods.

I´ve also tested with LOUD. And there it worked again. So I can only guess it has something todo with FAF itself.

One additional Note: Before I went to FAF I had Total Mayhem V136 and everything worked quite right.

@AI: Well I have tested with Sorian and UVESO, both they don´t seem to build any Defense structures when using FAF and Total Mayhem . When disabling all Mods, Sorian (builtin FAF right?) seems to build turrets again.

TLDR: On my installation (Steam)
.) Templates only work properly without FAF
.) AI (Uveso and Sorian) doesn´t build any defense structures when using FAF and Total Mayhem Mod.
.) When using the standalone Total Mayhem (V136) without FAF everything is working as well .

I have re-installed everything, still no change. Any further advice out there or do I just have bad luck?

cheers!

0

I can only tell you that the AI developers have all reported some level of problems with their AI after some kind of change. I'll let you know if there is more substance to it.

0

Many Thanks Sprouto!

0

I did some additional tests today and also found out that I had installed Total Mayhem from the vault, which is not the recommended way. Therefore, I decided to delete it and download/install it from the zipfile.
Now, the AI builds defense again!! Yeaah!!
Sooo, it seems, when using the vault´s mod, it will not work as it should (or it was just a conincidence?). So, the only thing left is the compromised template function which still doesn´t allow to add templates.

Cheers

0

Yes - it's not unusual for unit mods to inject their own 'builders' into the AI - which may or may not be compatible with that AI - or causing all kinds of unintended side effects.
I'm afraid I cannot address your templating issue however, you might wish to open another thread about that specifically.

0

Thanks Sproutu!
And regarding the template issue...well...its not that disturbing - I can live without it 🙂
cheers!

Log in to reply