Cant connect to games

HI there
I am trying to play some games with friends but I cant get the game to connect to any custom match no matter who I try to join. Previously the only way I could join at all was to use the force relay connection option which caused some lag when playing with friends but in public custom games the poor connection means I basically always get kicked.

To try and fix this issue i have tried the following:
-Reinstalled FAF client
-Added port forwarding to my router for port 6112
-Changed DNS server
-Restarted router and PC several time
-Turned off IPv6 in my network settings

Non of this has worked and I was hoping someone with better understanding might be able to help me trouble shoot. I know there are log files I am supposed to attached but I actually don't know where to find them.

Thanks guys

Edit: I have found the files, I will attach them

What kind of connection do you have?

edit: And disabling any security for testing purpose did not help either?
ran that test there
I don't currently have any internet security running besides windows defender

Try to test it with a VPN from a different country.

Edit: I am not that familiar with ICE Adapter errors, but there is a chance, (I guess), that the other player has just a very poor connection to Australia and loses it and vice versa. Maybe someone can jump in this thread and has better ideas.

I don't have a VPN to test it with