FAF stuck on connecting


When attempting to join an online match from the FAF client, after downloading any mods/maps, the ice adapter launches and the app opens but then I get stuck on the connecting or setting up automatch screen.

It appears to be similar to this issue, however I couldnt see a fix and its pretty old: https://forums.faforever.com/viewtopic.php?f=2&t=12762

So far I have checked my windows defender settings, reinstalled both supcom & FAF, attempted the force relay connection option and attempted to use the ICE debugger window which just shows I can connect to the host but not anyone else

Log - https://pastebin.com/LVd3mPRW

Does anyone have a fix for this?


You could also try:

  1. Disabling ipv6 in your windows system settings
  2. Using a VPN

Know Python? Want to contribute to FAF? https://forum.faforever.com/post/9801


Thank you, disabling ip6 appears to have worked!


I too suddenly started having this problem even though it's worked for a long time, but yes, disabling ipv6 seems to have fixed it