Authorisation problem

Same problem on alpha
Client Version: 2022.3.0-alpha-2
java.lang.IllegalStateException: Could not extract value with pattern 'code=([^ &]+)' from: ����~]�чy�V��2����K�r�%�@g�� N�<W�6�JJc�=��|��g9�l-�&���� �+�/�,�0̨̩����/5�ZZ localhost�
at com.faforever.client.login.OAuthValuesReceiver.extractValue(
at com.faforever.client.login.OAuthValuesReceiver.readValues(
at com.faforever.client.login.OAuthValuesReceiver.readWithUri(
at com.faforever.client.login.OAuthValuesReceiver.lambda$receiveValues$0(
at java.base/java.util.concurrent.CompletableFuture$
at java.base/java.util.concurrent.CompletableFuture$AsyncSupply.exec(
at java.base/java.util.concurrent.ForkJoinTask.doExec(
at java.base/java.util.concurrent.ForkJoinPool$WorkQueue.topLevelExec(
at java.base/java.util.concurrent.ForkJoinPool.scan(
at java.base/java.util.concurrent.ForkJoinPool.runWorker(
at java.base/

Could you give me more data? Which browser and OS do you use? OS language and browser language? And it would also be nice to see a screenshot where the browser's address bar is visible. To make sure it's not a browser or OS issue. Sorry for the inconvenience.

For example,

Hmmm. I'm not topic starter, but I changed default browser from Yandex Browser (Chromium) to Edge and login was successful.

@Sanchogus That's great! Welcome to FAF!

@marcspector I use Chrome (and try to login with edge - similar error). I use Windows Pro ver.21H2 x64. OS and launcher in English (previously was in Russian, renamed according to the above recommendation). I am attaching browser screenshots.



@sanchogus сhanged to Edge, but it did not help me. A year ago I installed a launcher on this computer and I didn’t have any problems ... but thanks for the advice

The value in address bar is ok. It looks like it's the client issue.

It is likely some character encoding issue but at this point I don't know what is causing it. I tried to specify that the socket we have to communicate with the browser should use utf-8 so not clear why it still comes back garbled. I also have not been able to replicate it on my machine.

@sheikah I reinstalled my sistem and only after that authorization in FAF was successful...

Any news on that?

Happened over night (without windows updates or anything else) on two different PC.
Client was 2023.3, now installed 2023.4, same issue.

Using Edge worked once, then also screwed.

Any ideas? Installing 2 PC Completely New is no option : D

last 2 days infinite authorization... no buttons available

upd: forced closing faf and restarting it helped