Cannot start FAF Client due to failure to link to Steam(when already linked)

I am trying to get into the Client and it will not start due to not having 'proof of ownership' with the latest update of the client. Was already linked to Steam, but client will not start and will not link stating 'already linked to account w/ login 'mandofanatic' (my login).

So I can't get the client because:
I can't link to Steam (which I am already linked to)
I can't prove I own the game (which I have for years and years)

Somebody help me here.

you are currently logged in as mandofan58 which is not mandofanatic. So make sure that you log in to the client using the user name mandofanatic. If you forgot the password for that account then request a password request on the website.

@sheikah Hello....and thank you. I did catch that login mistake today and tried to login the new way....still having the problem, but I appreciate your help. Better than some responses I have received (although I am a bit upset and maybe a bit harsh)....

But Thank You!

So when you login as mandofanatic what exactly is the error message you get?

I am recieving the same error. I really want to play but i cannot even login because of this steam link error.