Cant start game over FAF-client (Direct3D)

0

Hi Guys. Need your help.

The_after update from Win7 to WIN10_Story..🙄

there is a Info from WIN when i start it with FAF-client
"Direct3D cannot be generated. Please make sure that the system is equipped with the latest graphics drivers.

short time later there is the info from FAF_client

"java.lang.RuntimeException: Forged Alliance Crashed with exit code 1. See game_14962170.log for more information
at com.faforever.client.game.GameService.lambda$spawnTerminationListener$43(GameService.java:696)
at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1130)
at java.base/java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:630)
at java.base/java.lang.Thread.run(Thread.java:832)
"

the log file says:
"warning: GAL Exception: file : c:\work\rts\main\code\src\libs\gpggal\DeviceD3D9.cpp(189)
error: unable to create device
warning: GAL Exception: file : c:\work\rts\main\code\src\libs\gpggal\DeviceD3D9.cpp(189)
error: unable to create device"

I got the same WIN error message when I start via Steam. There I got the problem under control with the command line parameter: / windowed 1900 1080 (yes, it is not optimal to only play in the window)

But I have absolutely no idea how to do this under the FAF client ..... / windowed 1900 1080 somehow doesn't work in the command line.
Some Ideas/help? thx

For INFO: i did reinstall DirectX9 > didnt solve the problem
and yes, under WIN7 my videocard could handle the game and has the newest drivers..

0

Have you installed the c++ runtime files? It looks like it's shi**ing itself when it tries to run the cpp files. cpp are C++. I don't think the old C++ runtime files are installed with Win10. Basically, the C++ runtime files are the things that do stuff, the cpp are just telling them what to do.

Hopefully that fixes your problems. If not, let us know how you get on.

0

You can provide command line options for the game exe in the FAF options, the one that has "%s", i guess you could just put the options in there after the %s.

0

@youthenoob
i did install all versions c++runtime (2005-now) but same problem.. 😕
but guys, thx for your help until now

0

@katharsas
f.. my life 😁

%s was the missing part in the command /windowed 1900 1080 and now? tata 😇 , now i can play in windowed mode.

BUT why only in windowed mode? as a software nerd i have no plan, clue.
Any ideas?

0

You might want to fully reinstall your graphics driver and make sure you have no ingame overlays (like from Discord or RivaTuner/Afterburner) enabled.

0

Nvidia also has one of those overlays. It can be turned off in the settings.

Sorry but I'm confused as to why you need to run the commands? I know you can get certain performance improvements but for me just running FAF normally gives good enough settings. Could you not just start FAF normally and then change the resolution in-game?

Did the game run with the default settings?

0

@youthenoob

i wrote the answer of your question in my 1th post.
"Direct3D cannot be generated. Please make sure that the system is equipped with the latest graphics drivers."
means: didnt start over STEAM and FAF...
windowed=no problem

0

So in windows 10, with the default settings Steam > Forged alliance fails to open and gives the message?

Have you tried opening the program just using the executable? What happens? Have you tried changing compatibility settings on the exe? Right click on the exe, properties > compatibility. Try playing with all the settings. Running an in the 640 x 480 mode should at least run it, from there you can then change the resolution to whatever you want. Forged Alliance changes registry settings after it runs so your compatibility settings wont stick.

When FAF loads Forged Alliance the entire folder has been duplicated, with the relevant changes made to balancing etc.

Forged Alliance that is loaded by FAF and contains all the new balances.
"C:\ProgramData\FAForever\bin\ForgedAlliance.exe"

Default FAF install location with steam
"C:\Program Files (x86)\Steam\steamapps\common\Supreme Commander Forged Alliance\bin\SupremeCommander.exe"