Error when joining lobby

0

When I try to join a custom multiplayer game I get a notification that the ice adapter has started and then I get a black screen. I can still see my regular windows cursor and move it around but the rest of the screen is black. I get a window titled "Unhandled Exception" with the following code:

EXCEPTION_ACCESS_VIOLATION (0xc0000005) at address 0xe2afca1f
attempted to read memory at 0xe2afca1f

Program : C:\ProgramData\FAForever\bin\ForgedAlliance.exe
Cmd line arguments : /init init.lua /nobugreport /log C:\ProgramData\FAForever\logs\game_14394580.log /gpgnet 127.0.0.1:21801 /mean 1393.54 /deviation 107.506 /savereplay gpgnet://127.0.0.1:50772/14394580/JCOMMAND21.SCFAreplay /country CA /numgames 259

Callstack:
Unknown symbol (address 0xe2afca1f)
Unknown symbol (address 0x6233e08e)
Ordinal23 + 113856 bytes ((Unknown)(0) + 0 bytes)
Ordinal23 + 113510 bytes ((Unknown)(0) + 0 bytes)
Unknown symbol (address 0x008eecf5)

Last 100 lines of log...

debug: SND: Loaded SoundBank 'xsb'
debug: SND: Loaded SoundBank 'xsb_weapon'
debug: SND: Loaded SoundBank 'xsl'
debug: SND: Loaded SoundBank 'xsl_destroy'
debug: SND: Loaded SoundBank 'xsl_weapon'
debug: SND: Loaded SoundBank 'xss'
debug: SND: Loaded SoundBank 'xss_destroy'
debug: SND: Loaded SoundBank 'xss_weapon'
debug: MEM: -48236704 bytes SND
info: MD5 of global settings: d2a23d6464d3fd77956e7648c43b5077
info: IsStreamingWaveBank("/sounds/voice/us/briefings.xwb") => true
debug: SND: Loaded WaveBank 'briefings' at 2f20478
info: IsStreamingWaveBank("/sounds/voice/us/seraphim_language.xwb") => true
debug: SND: Loaded WaveBank 'seraphim_language' at 2f1fed8
info: IsStreamingWaveBank("/sounds/voice/us/x01_vo.xwb") => true
debug: SND: Loaded WaveBank 'x01_vo' at 2f20040
info: IsStreamingWaveBank("/sounds/voice/us/x02_vo.xwb") => true
debug: SND: Loaded WaveBank 'x02_vo' at 2f201a8
info: IsStreamingWaveBank("/sounds/voice/us/x03_vo.xwb") => true
debug: SND: Loaded WaveBank 'x03_vo' at 2f20310
info: IsStreamingWaveBank("/sounds/voice/us/x04_vo.xwb") => true
debug: SND: Loaded WaveBank 'x04_vo' at 2f35380
info: IsStreamingWaveBank("/sounds/voice/us/x05_vo.xwb") => true
debug: SND: Loaded WaveBank 'x05_vo' at 2f36190
info: IsStreamingWaveBank("/sounds/voice/us/x06_vo.xwb") => true
debug: SND: Loaded WaveBank 'x06_vo' at 2f362f8
info: IsStreamingWaveBank("/sounds/voice/us/x1t_vo.xwb") => true
debug: SND: Loaded WaveBank 'x1t_vo' at 2f354e8
info: IsStreamingWaveBank("/sounds/voice/us/x_fmv.xwb") => true
debug: SND: Loaded WaveBank 'x_fmv' at 2f36460
info: IsStreamingWaveBank("/sounds/voice/us/xgg.xwb") => true
debug: SND: Loaded WaveBank 'xgg' at 2f350b0
debug: SND: Loaded SoundBank 'briefings'
debug: SND: Loaded SoundBank 'x01_vo'
debug: SND: Loaded SoundBank 'x02_vo'
debug: SND: Loaded SoundBank 'x03_vo'
debug: SND: Loaded SoundBank 'x04_vo'
debug: SND: Loaded SoundBank 'x05_vo'
debug: SND: Loaded SoundBank 'x06_vo'
debug: SND: Loaded SoundBank 'x1t_vo'
debug: SND: Loaded SoundBank 'x_fmv'
debug: SND: Loaded SoundBank 'xgg'
debug: MEM: -796091502 bytes SND
info: MD5 of global settings: d2a23d6464d3fd77956e7648c43b5077
debug: MEM: -796091502 bytes SND
debug: Loading module '\000/lua/sim/buffdefinitions.lua\000'
debug: Loading module '\000/lua/sim/adjacencybuffs.lua\000'
debug: Loading module '\000/lua/sim/adjacencybufffunctions.lua\000'
info: Hooked /lua/sim/adjacencybufffunctions.lua with /schook/lua/sim/adjacencybufffunctions.lua
debug: Loading module '\000/lua/sim/cheatbuffs.lua\000'
debug: Loading module '\000/lua/user/prefs.lua\000'
debug: Loading module '\000/lua/options/optionslogic.lua\000'
debug: Loading module '\000/lua/ui/uiutil.lua\000'
debug: Loading module '\000/lua/lazyvar.lua\000'
debug: Loading module '\000/lua/maui/layouthelpers.lua\000'
debug: Loading module '\000/lua/maui/group.lua\000'
debug: Loading module '\000/lua/maui/control.lua\000'
debug: Loading module '\000/lua/maui/text.lua\000'
debug: Loading module '\000/lua/maui/multilinetext.lua\000'
debug: Loading module '\000/lua/maui/button.lua\000'
debug: Loading module '\000/lua/maui/bitmap.lua\000'
debug: Loading module '\000/lua/maui/dragger.lua\000'
debug: Loading module '\000/lua/maui/edit.lua\000'
debug: Loading module '\000/lua/utf.lua\000'
debug: Loading module '\000/lua/ui/controls/checkbox.lua\000'
debug: Loading module '\000/lua/maui/radiobuttons.lua\000'
debug: Loading module '\000/lua/maui/checkbox.lua\000'
debug: Loading module '\000/lua/maui/border.lua\000'
debug: Loading module '\000/lua/maui/scrollbar.lua\000'
debug: Loading module '\000/lua/maui/cursor.lua\000'
debug: Loading module '\000/lua/ui/controls/border.lua\000'
debug: Loading module '\000/lua/ui/controls/ninepatch.lua\000'
debug: Loading module '\000/lua/maui/itemlist.lua\000'
debug: Loading module '\000/lua/skins/layouts.lua\000'
debug: Loading module '\000/lua/ui/controls/popups/popup.lua\000'
debug: Loading module '\000/lua/ui/dialogs/eschandler.lua\000'
debug: Loading module '\000/lua/system/utils.lua\000'
debug: Loading module '\000/lua/ui/controls/popups/inputdialog.lua\000'
debug: Loading module '\000/lua/skins/skins.lua\000'
info: /savereplay
info: REPLAY ID: 50772
info: adding font file /fonts/arial.ttf
info: adding font file /fonts/arialbd.ttf
info: adding font file /fonts/arialbi.ttf
info: adding font file /fonts/ariali.ttf
info: adding font file /fonts/arialn.ttf
info: adding font file /fonts/arialnb.ttf
info: adding font file /fonts/arialnbi.ttf
info: adding font file /fonts/arialni.ttf
info: adding font file /fonts/ariblk.ttf
info: adding font file /fonts/arlrdbd.ttf
info: adding font file /fonts/butterbe.ttf
info: adding font file /fonts/vdub.ttf
info: adding font file /fonts/wintermu.ttf
info: adding font file /fonts/zeroes_3.ttf
debug: Loading module '\000/lua/keymap/keynames.lua\000'
debug: Loading module '\000/lua/keymap/keymapper.lua\000'
debug: Loading module '\000/lua/keymap/keydescriptions.lua\000'
debug: Loading module '\000/lua/keymap/keyactions.lua\000'
debug: Loading module '\000/lua/keymap/debugkeyactions.lua\000'

Here is the game log.game_14394485.log I think this is the error:

warning: Error running '/lua/ui/uimain.lua:ShowEscapeDialog': ...rever\gamedata\lua.nx2\lua\ui\dialogs\eschandler.lua(75): attempt to call method Show' (a nil value) stack traceback: ...rever\gamedata\lua.nx2\lua\ui\dialogs\eschandler.lua(75): in function CreateYesNoDialog'
...rever\gamedata\lua.nx2\lua\ui\dialogs\eschandler.lua(88): in function `HandleEsc'
...- forged alliance\gamedata\lua.scd\lua\ui\uimain.lua(108): in function <...- forged alliance\gamedata\lua.scd\lua\ui\uimain.lua:107>

I have reinstalled the client multiple times, to different hard drives, restarted computer, verified my windows os files, ran the windows RAM test.

I am on windows 10, intel i7-7800x, gtx 1070ti, 16Gbs of RAM.

Any suggestions are much appreciated.

cheers
Jamie

0
c:\program files (x86)\thq\gas powered games\supreme commander - forged alliance\gamedata\ambience.scd

Looks like this file is missing ?

Please reinstall your game to c:\program files (x86)\thq\gas powered games\supreme commander - forged alliance\

Also delete ALL files inside this folder:

C:\ProgramData\FAForever\gamedata

Then try again.