Local Game freezes after 15-20 mins

Hi all,

I have been experiencing problems lately when playing locally vs Sorain AIx. I will post the logs as well.

For every game I play, the game time freezes/stops after around 15-20 mins, to be more precise: I can select units, issue orders, zoom in and out, move around the map etc, but the game behaves as if I pressed pause (which I didn't, pausing and unpausing does not help). When trying to exit the game to desktop, it does crash and cannot be shut down normally. Just leaving the game be for a while (15 mins) does not reinitiate game time either.

After force quitting the game through task manager I get the following error message:

java.lang.RuntimeException: Forged Alliance Crashed with exit code 1. See game_14310649.log for more information
at com.faforever.client.game.GameService.lambda$spawnTerminationListener$45(GameService.java:719)
at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1130)
at java.base/java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:630)
at java.base/java.lang.Thread.run(Thread.java:832)

While I had an occasional crash/freeze before, this new behaviour seems to appear every new game I start. I've tried searching the forums, but could not find a 'game time freezes but game itself still works' kind of error.

I've tried reinstalling the client, that did not work. If it helps, I played these games with the Total Mayhem mod (but had no issues with it earlier).

System should be having no direct performance issues (Ryzen 3600, RTX 2600, 16GB RAM).

If you need more information please let me know. Hopefully you can help me with this problem.