FAF doesn't "know" where localisation files are !

Everytime I launch FAF, my FA v1.6.6 (Steam) is turned to English language, while it was initialy in my native language.

The problem :
FAF has changed my game.prefs for an incorrect language !
Open AppData\Local\Gas Powered Games\Supreme Commander Forged Alliance\Game.prefs and take a look at :

  • the field language = 'us',
  • the field selectedlanguage = 'us',

while these should be set on my country code...

Also, FAF is ignoring where to access the good old localised audio folder and files :

  • When I set it to some language, the Tutos won't play given they're in english because the engine is "lost in translation"..
  • FAF is set to english by default and doesn't set for us the proper localisation.

Last but not least :
I noticed that the visual parts of the speeches aka videos were hugely accelerated with no audio. (like 5 times faster)
IMHO this means the XACT Audio engine is one of the main cause of FA's slowdowns...

More about this issue :

I've noticed by verifying "AppData\Local\Gas Powered Games\Supreme Commander Forged Alliance\Game.prefs" that the voice volume was OFF, while it was at MAX in the Options window in-game :

options = {
    vo_volume = 0,

The localized voices are still muted in spite of my attempts to :

  • set the volume to the MAX from the Options window in-game.
  • click on [Apply].
  • click on [OK].

I've even thought I had to quit the game and launch it again after this change, to no avail.

I've openned game.prefs with NP++ and noticed the value was still vo_volume = 0,.
So I've changed it for vo_volume = 100,, but it's had no effect at all.

FA v1.6.6 's localized voices are definitely like "broken" since I installed FAF, even by running the game without FAF.

Help will be much appreciated.