can't autorizate

0

Is autirization works fine?
I can't log in in to the FAF.

java.lang.IllegalStateException: Could not extract value with pattern 'code=([^ &]+)' from: GET /favicon.ico HTTP/1.1
at com.faforever.client.login.OAuthValuesReceiver.extractValue(OAuthValuesReceiver.java:149)
at com.faforever.client.login.OAuthValuesReceiver.readValues(OAuthValuesReceiver.java:141)
at com.faforever.client.login.OAuthValuesReceiver.readWithUri(OAuthValuesReceiver.java:103)
at com.faforever.client.login.OAuthValuesReceiver.lambda$receiveValues$1(OAuthValuesReceiver.java:65)
at java.base/java.util.concurrent.CompletableFuture$AsyncSupply.run(CompletableFuture.java:1768)
at java.base/java.util.concurrent.CompletableFuture$AsyncSupply.exec(CompletableFuture.java:1760)
at java.base/java.util.concurrent.ForkJoinTask.doExec(ForkJoinTask.java:373)
at java.base/java.util.concurrent.ForkJoinPool$WorkQueue.topLevelExec(ForkJoinPool.java:1182)
at java.base/java.util.concurrent.ForkJoinPool.scan(ForkJoinPool.java:1655)
at java.base/java.util.concurrent.ForkJoinPool.runWorker(ForkJoinPool.java:1622)
at java.base/java.util.concurrent.ForkJoinWorkerThread.run(ForkJoinWorkerThread.java:165)

0

never mind. everything fixed somehow.

0

How did you fix this? I updated my client and cannot get past this error. I've reinstalled, uninstalled, restarted, installed again, etc.

0

Which browser do you use for authorization?
Have you tried changing the default browser?

0

By default, I use Chrome. However I changed my default browser to Edge to try to resolve the issue with no success. I rebooted in between changing the default browser, just to make sure, with no success.

Edit: I am at work at the moment, but it dawns on me that because I am part of the Windows Insider Program, my OS has updated to Windows 11 22H2 before the update's feature release this autumn. I believe this update happened only a handful of days ago. If I had to place bets on what is causing me to have login issues, I would put money on that. I could remove myself from the Program and roll back Windows to pre-22H2 as a test. Or, perhaps I could try to understand what changed. It could be that others will experience this problem when the update rolls out later this year so maybe I can give the dev team a leg up on incoming issues.

0
This post is deleted!
1

I wanted to come back and update this thread for others who may have this issue. I was only able to log in by downloading Firefox and setting it as my default browser. Once I did that, it successfully authenticated me. Things to note:

  • Chrome did not work (Chrome already existed on my machine)
  • Edge did not work (Edge already existed on my machine)
  • Firefox worked; Firefox was not previously installed on my machine; it was a fresh install (no idea if this being a fresh install mattered)
  • Uninstalling/reinstalling FAF did not help
  • Other FAF clients did not work (only tried Ethereal - not sure if there are others out there)