Linux Support

1

I did miss that step, but have changed that and now I am able to join and create games. I tested in a 1v1 and was able to play through the entire game. Thanks for the help.

2

Proton 5.13-1 is out!
Test pls!

0

testing.

0

works brilliant for me. I got way faster game ForgedAlliance.exe boot-up time. nothing else to remark on.

0

really?
because the generated run file for 5.13 is different for me than for 5.09 (i regenerated 5.09 as well, it is not old).

if i just run the run 5.09 file from terminal the original game launches.
if i run the 5.13 file nothing happens. it is working with launching from Steam, but not from terminal or from the client.

i get this in terminal:

wineserver: using server-side synchronization.
Wine cannot find the FreeType font library.  To enable Wine to
use TrueType fonts please install a version of FreeType greater than
or equal to 2.0.5.
http://www.freetype.org
Setting breakpad minidump AppID = 9420
Steam_SetMinidumpSteamID:  Caching Steam ID:  76561198445101600 [API loaded no]```
0

make sure steam is running.

i dunno what to say works utterly brilliant for me.

0

step 1. uninstall linux

1

@nine2 said in Linux Support:

step 1. uninstall linux

hehe funneh!
just support monopolistic giga corporations with you everyday life decisions.
that are cannot be controlled by society at all. in fact, people are exposed to their decisions. they directly associate with corruption. it makes sense.
https://www.youtube.com/watch?v=Ag1AKIl_2GM

0

@tatsu said in Linux Support:

make sure steam is running.

i dunno what to say works utterly brilliant for me.

how does your Proton 5.13 run file look like?
this is mine. the PATH variable is noticeably shorter in it:
https://gist.github.com/foodlfg/d104c6d42e14d6929a0e8626c8edaeb6#file-supcom-proton513-run-file

0

I was hoping for some fix for the missing effects but alas it's still the same.

0

@Whatsisname
what is about your Proton 5.13 run file btw?
working fine?

0

Hi, can't understand what's wrong with my setup. I tried to follow instructions, on first launch it exits with code 1, says that wine can't find freetype2 fonts family, so I install 32 version of it, and error gone.

Now when I try to create game, It does nothings, logs give me exit with code 0. Like this

2020-11-08 13:29:58.803 INFO 4686 --- [ Thread-110] c.f.client.fa.ForgedAllianceService : Starting Forged Alliance with command: [/home/vitautart/apps/faf/client/1.2.2/run, /home/vitautart/.faforever/bin/ForgedAlliance.exe, /init, init.lua, /nobugreport, /log, /home/vitautart/.faforever/logs/game_13067128.log, /gpgnet, 127.0.0.1:21521, /mean, 1892.75, /deviation, 301.084, /savereplay, gpgnet://127.0.0.1:33127/13067128/vitautart.SCFAreplay, /country, UA, /numgames, 7] in directory: /home/vitautart/.faforever/bin
wineserver: using server-side synchronization.
Setting breakpad minidump AppID = ****
Steam_SetMinidumpSteamID: Caching Steam ID: ****************** [API loaded no]
2020-11-08 13:30:00.506 INFO 4686 --- [pool-3-thread-2] com.faforever.client.game.GameService : Forged Alliance terminated with exit code 0
2020-11-08 13:30:00.832 INFO 4686 --- [ Thread-110] c.f.client.fa.relay.ice.IceAdapterImpl : ICE adapter terminated normally

System: ArchLinux
WM: dwm
Proton 5.13

Vanilla FA works fine in steam.

0

@vitautart
yeh. i have the same problem with Proton 5.13
Steam generates a different run file for Proton 5.13 than for the previous ones.
if you want to track down the issue, i would start there.

meanwhile. use an older Proton version.

btw the wiki is not saying to use Proton 5.13, it is not in the compatible list...
it says "Proton 5.0-9 (recommended)"

1

@foodlfg
Thanks. Downgraded proton version in steam to 5.0, and all works. Seams like there is some bugs with 5.13 proton run script.

0

guys that happens if you close steam.

0

Anyone else getting crashes with replays? Pretty much every replay crashes for me at random times, sometimes 10 minutes in to the replay, sometimes 30.

This is with Proton 5.0 and Nvidia 455.38 drivers.

0

no. no replay crashes for me.

proton : 5.13-1
nvidia : 450

it's probably the nvidia 455 driver. that sound a bit too hot off the press.

0

I'm pretty sure I've had the replay crashes for a while now, long before 455 but I've never tried Proton 5.13, let me test with that.

1

@tatsu said in Linux Support:

guys that happens if you close steam.

This is also very weird because with Proton 5.0 and below you never had to have Steam running.

EDIT: This can be fixed by removing "steam.exe" from the last line of your "run" file.

0

OK with Proton 5.13 I have no crashes so far, 40 minutes into a game.

I've also just realized I've been playing with D3D9 all this time! I just switched to D9VK and the game is soo much smoother!

Now, my only remaining issue is all the missing effects but I guess there is no solution to that 😞