Game Crash on "Create Game" Linux


Thank you, however I'm not using WINE. Steam only (with Proton).

Proton is just wine plus some extra stuff, so yea you are using it.


Thank you; I have tried 'blank' and "%s" neither worked.
Just retried, to be sure, and no neither worked.
"Exit code 2"

Thanks for the correction. I thought Proton was Steam/Value's API that could work with WINE, not that it was an extension of it.
Do I need to install wine ? Typing # wine or # wine --help certainly confirms that WINE is not installed.

@Zarrex can you post screenshots of your launch command settings from the FAF client and steam?

All of is kind of confusing for me, there is exactly one location where %s works, which is inside the FAF client settings under "Command line format for executable".

When the client starts the game, it will replace %s with the path to the FA executable. You can modifiy the command so the client adds additional parameters, for example %s /nosound should start the game with /nosound parameter. I have no idea what %command% is so i cannot help with that.

Then there is this part of your log:

/home/andyh/.faforever/bin/ForgedAlliance.exe: 1: MZ����@0��: not found
/home/andyh/.faforever/bin/ForgedAlliance.exe: 1: Syntax error: word unexpected (expecting ")")

Is this really what is inside the log? Its better to post the log as file attachment so we know if this is a forum problem with encoding or if that is actually in the log. Btw the forum uses markdown, so you can use backticks ` to make it clearer when you cite a value.

Hi there, same problem here, on ubuntu(kubuntu) 22.10:

2023-01-04 12:06:32.903 INFO 37568 --- [r-http-epoll-16] c.f.client.fa.ForgedAllianceService : Starting Forged Alliance with command: [%USER_PROFILE%/.faforever/bin/FAFDebugger.exe, %USER_PROFILE%/.faforever/bin/ForgedAlliance.exe, /init, init.lua, /nobugreport, /log, %USER_PROFILE%/.faforever/logs/game_18912593.log, /gpgnet,, /mean, 1485.16, /deviation, 446.046, /savereplay, gpgnet://, /country, IT, /numgames, 1, /numgames, 1] in directory: %USER_PROFILE%/.faforever/bin
/home/xyz/.faforever/bin/FAFDebugger.exe: 1: MZP���@▒��: not found
/home/xyz/.faforever/bin/FAFDebugger.exe: 2: /gpgnetPEL: not found
/home/xyz/.faforever/bin/FAFDebugger.exe: 9: Syntax error: word unexpected (expecting ")")

-fresh steam install, which works, with command params: PROTON_NO_ESYNC=1 PROTON_NO_FSYNC=1 %command% (the error is the same if i remove steam additional params)
-faforever installed with linux script
-try to launch a game, the game fails to starts (and in steam it shows that it is still running)
-if i try to run the run-offline executable, it crashes with this error

wineserver: using server-side synchronization.
wine: RLIMIT_NICE is <= 20, unable to use setpriority safely
wine: could not load kernel32.dll, status c0000135

it looks like wine/libraries is missing BUT idk if the offline executable needs to be launched with additional params (eg. PREFIX)

any ideas?

EDIT: i completely removed FA from steam, uninstalled wine and removed the ~/.wine, faforever and faf-linux folders...i rebooted and reinstalled everything from the beginning (steam, proton 7(not experimental) with params, faf-linux) run-offline works correctly and the game starts BUT the lobby still crashed creating a game

EDIT2: after a little bit of digging i discovered various issues with my system..i'll write them here for future users:

-i had a custom repo (ondrej/php) in my system which installed a library (libgd3) version which the amd64 and i386 had incompatibilities between each other (they coundn't be installed together)...i solved by 1) removing the custom repo 2) installing both the libraries needed for my system and wine (libgd3:i386 and libgd3:amd64) 3) installed wine 4) re-added the repo but i pinned/locked the packages installed previously (apt-mark) in their version from the base repo

-at the same time faf-linux creates a local wine prefix in its folder...once the wine installation was broken in the system, the setup script continued to fail until i deleted the faf-linux folder and cloned the repository again (and than executed the script)

in synthesis, on ubuntu 22.04/22.10:
-be sure to install a working wine (32/i386)
-follow the instructions on faf-linux repository
-the game should work perfectly running the run-offline script

i'm still having issues running it from the lobby

I had the same issue as you, and managed to get past it. In my case, it was because had not been executed after my first log in. Hopefully this helps someone else with the issue.

Perhaps you have the same problem. Try running the shell script.

Having this issue as well, exit code 53 really is not very descriptive, for me anyway. @psyrg s post above did not help.

Help? Anyone?

The issue still persists. Someone please advice, I am locked out of playing the game as it stands for now.
I attached the log file the client creates when it fails.