Friend getting kicked for not having mods, despite DLing them each time

0

Ok, so Vault Fallback Location was NOT ticked, and turning it ON did not fix the problem. 😕

a5b4a19f-1eba-4f09-bc34-410e6e68f916-image.png

This is what I see from the lobby. Maddleaf says joining my game attempted to download BlackOps and AI-Uveso, but as you can see, it still didn't register that the mods were added.

Any other ideas? I am loathing having to do an audit of their files comparing them to mine remotely, but it's looking like that's my next step unless someone knows what's going on here.

Thx.

0

Another thing can be that you need to untick the Fallback Vault Location which is located at the top left of the client under settings.

0

1.check if guys have the same version of the mods
2.uninstal it and ask your friend to give you the archived mod,unarchive the mod in your ''mod'' folder
3,check if you have the core mods (some mods like brewlan units and some other UI mods require the core mods like common mod tools,brewlan)

0

Thank you for responses, but still stuck on this.

@Rowey - We have tried ticking and unticking the Fallback Location, and friend still downloads the maps and mods upon joining game, but is kicked with the message that they don't have them when they load into the lobby.

@Resistance - We only use mods that are in the Mod Vault, and it is trying to download them (which should automatically get the correct version) but unless anyone comes up with a wizard explanation, I guess it's going to come down to helping them audit their system and see what they could have missed deleting the last time they removed and reinstalled everything.

0

What happens if they host?

0

@Brutus5000 said in Friend getting kicked for not having mods, despite DLing them each time:

By default maps & mods are saved below C:\ProgramData which used to work for years. Lately we run into problems accessing the files there for whatever reason (mostly related to Microsoft OneDrive installations).
If you activate the fallback location, the client stores the files in your userdata directory which usually just works.

I highly doubt unticking the option will solve the issue.

Its the other way around:
By default (without ticking the vault fallback location), the mods are stored here:

C:\Users\<USER>\Documents\my games\Gas Powered Games\Supreme Commander Forged Alliance

If you tick the fallback location, mods will instead be stored here:

C:\ProgramData\FAForever\user\My Games\Gas Powered Games\Supreme Commander Forged Alliance

You can easily open those folders from the client by clicking on the hamburger menu and clicking on "mods" and check if the mods are there.

1

@Katharsas the default for new client installs was changed to the fallback location due to many users having issues with the default game location due to system issues or oneDrive

0

your friend should post his game and client log

0

Client log is attached to first post. There's some java error stuff in there. Not sure if that's relevant or important.

Most recently, they have attempted uninstalling everything again, and deleting every relevant folder they can find, and reinstalling (This time client 1.3 instead of 1.2.3). We were going to test on Friday but something came up. Will update if it's fixed or still a problem. Sorry I'm doing this 2nd hand. Troubeshooting logs is not their thing. It's barely mine as you can probably tell. 😄

It's just a PITA that we played fine for ages and this one day it didn't work, with no idea what changed.

0

There is an error on uploading a mod in the log. If you are playing this mod your friend has the newest version but the rest of you don't.

0

@Brutus5000 said in Friend getting kicked for not having mods, despite DLing them each time:

There is an error on uploading a mod in the log. If you are playing this mod your friend has the newest version but the rest of you don't.

So worked on this last night and still no solution. The mods currently causing problems are BlackOps: Unleashed and BlackOps: EXUnits. (BlackOps: ACUs works for some reason). We have doublechecked that we are both on version 19 from the mod vault. At one point, I have even zipped up my mod folder and sent it to them to unzip -- Regardless of how we make sure the mods are installed, what happens is;

IF I HOST:

a) They attempt to join my game
b) FAF attempts to download the BlackOps mods (even though they have the them)
c) When they complete the DL, it installs it overtop the mods we already had installed.
d) They then join and are insta-kicked because it says they don't have the mods.

IF THEY HOST:

A) they cannot start a game with the BlackOps and EXUnits mods.. only BlackOps ACU. Mod manager in the lobby says they do not have the mod.

And Like I say, they have uninstalled, deleted all folders, and reinstalled.. we have zipped my mod folder up.. We have tried checking/unchecking vault fallback.

It's just that no matter what files are in the mod folder, it tries to DL files from the mod vault, and then can't see those files (or they're corrupt) or something.