I can't hear some of the Audio or other Sound issue. What should I do?

3

You need to make sure your audio is configured to stereo 16bit 44100MHz.

first set it to stereo, you do this by opening the old windows audio settings menu (go to configure) :

669afd46-1b96-48d3-b148-588a2d74695c-image.png
Now select Stereo :

eb531897-a516-4c5f-8e87-41aeca9f365a-image.png

Then you can set it to 44100 Hz in the "Advanced" tab :

d999a623-d6c7-43ec-8b8d-93f9a78122c0-image.png

there. you're now in stereo audio but there's a good chance this won't be enough if the first time you installed and ran FA, your computer was configured to use surround sound audio.

to persist these changes into FA, delete your Game.prefs file at (warning you'll loose your FA user config for example what mods are enabled, what settings you set, build templates) :

%LOCALAPPDATA%\Gas Powered Games\Supreme Commander Forged Alliance\Game.prefs

and re-create it by running Forged Alliance from steam and re-creating your username.

Now FA understands that it is in a stereo environment and audio will work.

You can remake your templates, and add your settings and ui mods back.

The bottom line is Forged Alliance and 5.1 or 7.1 surround sound are incompatible as FA was built before these techs were on the market so you have to choose.

however, in my experience. so long as FA is shut down when you switch your audio back to 5.1 or 7.1 and you switch your audio back to stereo before running FA again, everything works out.

2

Let's avoid any misunderstanding so here's some correct pics:

e67d8ee3-6917-4326-abb3-0f7b166e1fdb-image.png

86806433-eb2f-43b0-9ae0-dce64d6ab965-image.png

0

thanks I replaced the one's I'd found online with yours.

0

Any idea if there is a work around if you can't change the Default Audio Format (it's greyed out and doesn't let me choose anything other then 16 bit, 44800 HZ DVD Quality). I am using Claud Alpha S headset and I couldn't find anything online.

0

it's possible you need you install the audio driver corresponding to your hardware. if you have a desktop PC you need to go the the manufacturer's motherboard's webpage on the exact page for that specific model of motherboard and if you have a laptop on the manufacturer's page for that exact model and they'll have a support tab where you can download drivers. check under audio and get everything there. This applies if you reinstalled windows fresh and have not manually installed any drivers aside from graphics drivers.

It's also possible that 16 bit, 44800 HZ DVD Quality works, did you try it?

0

44800 HZ DVD quality works but it sounds different, the levels of audio are different which you can get adjusted to but it's annoying. I will try out downloading drivers later today.

1

Recently I lost a lot of sounds after a Windows update (in particular mantis firing). This has happened previously for me. In the past I found that disconnecting and reconnecting my headphones resolved the issue, but not in this case. I had to totally reinstall motherboard manufacturer recommended audio drivers (from ASUS). Unfortunately they come bundled with Sonic Studio and Sound Radar which even when all audio enhancements are turned off and sound is set to stereo still results in crashes with XACT sound errors in the log. I resolved this by completely uninstalling Sonic Studio and sound radar crap. Thought I'd post in case anyone else has similar issues.

0

For me it was some msi bloatware called nahimic that installed itself that messed with my projectile sounds. Removing it from startup and deactivating the virtual sound device in device manager fixed it. Maybe thats a new thing since it just happend to me last week after running the pc for 1.5 years

1

It's very common for unspecified Windows updates to reset audio hardware and other settings. Recently (last 6 months or so) they've introduced a new option for psuedo-surround sound which is playing havoc with Forged Alliance. Best advice - goto your hardware manager and remove (disable) all the extra sound devices you don't use. Remember, many monitors have built-in audio capability these days, and as was pointed out above, a lot of headsets use 'virtual surround' drivers that have a lot to do with frequent crashes.

0

I have the same problem, the sounds disappear. I set the settings correctly, completely reinstalled faf, but still no sounds(

0

It's not FAF. You need to reinstall audio drivers

0

I also got this error out of the blue and a simple uninstall of Nahimic seems to have fixed it. The internet tells me I might need to do it again if some random update reinstalls it on me, but just thought I'd bump this thread for the next MSI motherboard user.

0
This post is deleted!