Resolution does not fit to screen in-game

By launching the game without the client, I tried to choose either my native resolution (1980X1024) or the windowed mode but when I launch let's say a coop campaign match through the client, the in-game menu does not fit my screen and all the right side is inaccessible.

A few months ago I was able to play the entire campaign perfectly but on another monitor. Any help appreciated.

It should be possible to manually change the resolution in the config file.

Find this line "primary_adapter = '2560,1440,120'," and change the resolution so that it fits your screen.
Mind that the numbers here are from my own config file so they will vary from yours.
You can also find all the supported resolutions under the line "primary_adapter = {"

As to how get the config? Just open the client, click on the 3 stripes in the left top corner. This will open a menu in which you will choose the "show game prefs file". Open the game.pref in text editor and find the lines so that you can edit them.

Can always try

Never Fear, A Geek is Here!

@xiaomao Thank you for the quick reply. I tried what you described. I change the config file appropriately.

EX. primary_adapter = {
default = '1920,1080,60',

Save the file and try to launch a coop campaign through the client again but same problem. I went and check the config file afterwards to make sure but the line about default resolution in the config file keeps being changed to 1024,768,60 every time I launch the game. I tried making the config file ''read only'' but the game just create another config files with the undesired resolution.

I'll check the other suggestion in the comments. Thank you for your time.

@davaeron said in Resolution does not fit to screen in-game:

I'll check the other suggestion in the comments.

Yeah let me know if it solves your issue, just make FA run in windowed mode and set your game install location (and FAF install location) in settings in DSCL.

Never Fear, A Geek is Here!

Don't change the "default" line as that won't do anything due to the game getting it's resolution from deeper down. Change the first line of code I posted "primary_adapter = '2560,1440,120',". It is actually a different line from the "default" one, that is hidden way deeper into the file, like at the end of it where all the in-game options are. The line with" {" is totally a different thing that you don't wanna be changing.


That's where the line you wanna change is hidden.

Also pardon me for being bad at explaining. It being 3am and me not sleeping much this year doesn't help.

@xiaomao I'm currently trying to improve a vital interchange in C:S but as soon as my redbull kick in I will change the settings you shown in your screenshot. I wish I could buy you a beer or some iced tea.

@thecore said in Resolution does not fit to screen in-game:

Can always try

I'm not sure how to install this launcher. I think it is beyond my skills.


I found the line at the bottom of the file and it was already set to my monitor native resolution. Still the same problem. I tried changing it to ''windowed'' and the game start in a window all right but I'm still missing a part of the right and bottom part of the screen. This is so frustrating. I love playing the campaign once a year. Oh well.

Sorry, I have no ideas then. What you can do is try to join the official FAF discord and ask in the tech-forum there as way more people use it than forums here. Also, it might be good to post some screen shots of your problem when you make a topic on discord.

@davaeron Hey, just go to releases and download the and run the exe.

Never Fear, A Geek is Here!

@Davaeron In all the other Options settings in the screenshot Xiaomao showed should be the setting for ui_scale. Change that to 1 to return the UI scaling to 100%.

Try to open the properties on exe file of the game in task manager, then compatibility and settings of high DPI. using 1 of 2 options there may help