Saving your game in Coop/Campaign?

i was playing a custom campaign and was 1,5 hours in when the guy i was supposed to protect suicided into the enemy forces and now i have to do all of that again because i couldn't find any way to save the game.
Am i missing something?

@inspexor This should help!

This post is deleted!

@deletethis I think it's working. Haven't fully tested it yet but the save and load buttons are there at least.
Thank you my dude.

@inspexor Possibly I'm mixing topics here so assume this source is unreliable.

I've had good luck saving skirmish games after launching with init_coop.lua

So far I've not been able to save and load a regular campaign mission. I can't remember the exact behavior now - it has been ~6 weeks since I tried. I'll try to add links to a couple of threads that looked pertinent to me.
link load-save-broken
link load-save-under-repair

But my attempt was with the regular campaign. You mention a custom campaign so your experience may be different. @deletethis should have a better idea than me.

Why are you pulling older threads rather than the newer ones? Saving and loading for custom campaigns has been (re)fixed for a while.

The regular campaign missions are unsupported by FAF, which is why we have the custom FAF versions.

I appreciate that you wanted to help, but what exactly was the goal of the post when his issue was already fixed, your own issue is irrelevant, and the threads you linked to are outdated?

@deletethis abject apologies. I did so many things wrong here that a concise explanation won't be possible.

I had chosen e.g Black Day and Dawn from the coop tab of the client Play page, in order to download the maps. In my earlier post in this thread, I referred to those as "regular"; likely yet another mistake.

As I try to re-trace my steps, it becomes apparent that a) I'm still not following the directions in your linked thread, and/or b) there are problems with my setup, resulting in my inability to save. I'll pursue that elsewhere.

In my earlier (6 weeks ago) struggle to resolve my issues, I found those old threads. Not finding a thread on the forum specifically saying it was fixed, I ASSumed it was still broken. (No, I didn't review subsequent patch release notes.)

So, a) I thought that what the OP was attempting to do was similar to what I was failing to do, and b) I thought it was still broken. Apologies for the additional hot air, but you did say "why".

@inspexor said in Saving your game in Coop/Campaign?:

@deletethis I think it's working. Haven't fully tested it yet but the save and load buttons are there at least.
Thank you my dude.

Unfortunately i tested it and it's not working.
The missions disappear after loading a game, softlocking you with no way to progress.

Getting pretty sick of starting all over again after failing a single objective but it has some hardcore vibes like Dark Souls so you actually try hard to succeed.
That's the "good" part i guess.

@Inspexor can you record how you start the game and save / load? Then I can see if I can reproduce it

A work of art is never finished, merely abandoned


It's not just an UI bug i tested it. If it's a mission where you have to kill something or survive x amount of time you're definitely softlocked.

@Inspexor I retraced your steps and it works fine for me. Can you open the log (f9 or ctrl + f9). Enable 'info'. Scroll to the top. There you'll find this:

INFO: Client version: 2023.3.0-alpha-2
INFO: Game version: 3756
INFO: Game type: coop

Can you confirm that your game version is 3756 too? If not, then host 1 game using the FAF game type. That will update your game. The save / load sequence in your video works with the latest patch.

Old save games can no longer be loaded when updating the game version.

A work of art is never finished, merely abandoned

INFO: Client version: 2023.2.0
INFO: Game version: 3756
INFO: Game type: coop

Yep, it's 3756.

I followed your other instructions anyways but it didn't change anything.
The problem persists.

Do you play with UI mods? If so, try without

A work of art is never finished, merely abandoned

@jip I don't play with UI mods.

Doesn't seem like anybody knows the solution. Guess i'm just gonna keep playing on hardcore mode then.
Thanks for trying to help.