Error Code -1073741819 on lobby launch

0

I have been getting this error on occasion when trying to join a lobby:

"It looks like Supreme Commander: Forged Alliance crashed check with exit code - 1,073,741,819 the game log [filepath] for more information."

When this happens, the game log is ALWAYS the most recent replay file.

The ONLY way I have found to get the game to run again is to restart my computer.

I have also tried:

  • Deleting the replay file
  • Deleting the game.prefs file
  • Uninstalling and reinstalling the game
  • Uninstalling and reinstalling Steam
  • Deleting all my mods

None of these work.

When the issue is fixed, it is usually fixed for a while—a day, sometimes a few. However, sometimes it happens again immediately. I have been putting off posting this because restarting my computer isn't that bad... but then today, restarting no longer fixes it. So I cannot play FAF.

plz halp

Example log file (but again, it's never the same file, just the most recent replay):
game_18883104.log

0

Try to fix those things first:

  • remove deprecated mods
  • then disable all mods
  • don't have duplicated Hotbuild keys

Then test again and try to reproduce the crash

It crashes, probably related to:

Error line: warning: Error running OnRelease script in <deleted object>: ...mdata\faforever\gamedata\lua.nx2\lua\maui\button.lua(101): Game object has been destroyed

But without the above fixes, I am not sure if those are causing that stuff in the first place.

If you need to know which keys or mods, just reply again and I can summarize it. (Just search log with "warning" and it will tell you what is going on)

0

All mods deselected, still get the error.

With the latest patch all my hotkeys were reset so that can't be the issue either.

0

Delete all logs, replicate error, post last log please

1

Have you tried starting the game with the debugger attached to it?

869be4db-1689-449f-84ff-6fd6ec222a22-image.png

That should always generate a log.

@magge the error you posted:

Error line: warning: Error running OnRelease script in <deleted object>: ...mdata\faforever\gamedata\lua.nx2\lua\maui\button.lua(101): Game object has been destroyed

is a UI error, usually related to the score screen. It is harmless.

A work of art is never finished, merely abandoned

0

When I delete all game logs and launch without debug mode on, no new log file is generated. Here is the client.log file, which I cannot delete with FAF running, and which appears to be updated every time I try and launch a game:

client.log

With debugger on, here's the file that's generated:

game_18956283.log

0

@Pearl12 I've asked one of our assembly devs, he answered with:

error in ntdll.dll RtlEnterCriticalSection.
An extraneous Citrix ICA Client dll was loaded into the process.

Maybe it rings a bell?

A work of art is never finished, merely abandoned

0

Game found a virus xdddd

My github repo with UI Mods

0

@jip said in Error Code -1073741819 on lobby launch:

@Pearl12 I've asked one of our assembly devs, he answered with:

error in ntdll.dll RtlEnterCriticalSection.
An extraneous Citrix ICA Client dll was loaded into the process.

Maybe it rings a bell?

I do have a Citrix client installed on my computer for work but I don't use it except once a month for expense reports and I get this error much more than once a month. I can double check next time I get the error (I just checked now and I do not get the error, there is a process called "Citrix Analytics Server" running in the background, so at least we know that's not it).

I also don't understand why this would happen sometimes and not others unless the Citrix client turns itself on and off, seemingly randomly.

@ctrl-k said in Error Code -1073741819 on lobby launch:

Game found a virus xdddd

This isn't helpful.

0

The main question is why Citrix ICA Client dll is loaded into the process?
What is the relationship between Citrix Analytics Server and FAF?
I suppose in a normal situation this should not be.