Game freezes and Crashes in FaF singleplayer and multiplayer 100% of the time within 10-50 minutes.

1

It still looks like an audio issue to me, one of your last lines in the crashlog says "warning: SND: Error playing cue 1 on bank 5 [music]". You'll notice it's the same as the ones you were getting in the previous crashlog.

Are you -REALLY- sure you have configured your audio as stereo under windows and not as
5.1/7.1/surround/whatever?

Try looking up your error on google, you'll get some more insights and tips.

It might be a device incompatibility, or it might be because you are plugging it through USB instead of the audio jack, or it might be the device-specific software giving problems (try closing it or double check the settings there).

One of the discussions that you will find mentions deleting the music files from the game as a "fix", you might want to try that (make sure to make a backup just in case, so you won't have to redownload/reinstall).

1

This is definitely a sound configuration issue - the final message in that crashlog that refers to the XACT issue, confirms it.

0

@deletethis It's always been set to stereo so I never tried changing it to something else and back to Stereo. I can try testing it when I'm available again. I use regular headphones plugged into the audio jack of my PC. I'll definitely try deleting the music files too when I'm available again. I'll keep you updated.

5.JPG

0

@Sprouto I'm glad it's narrowed down to that at least. I can try reinstalling audio drivers again when I'm available. But my speaker's configuration has always been set to stereo. I've never changed it.

0

@Pearl12 The only mod I've used, if it counts, is Nomads, but the problem has been happening before and after I've installed Nomads, and after I reinstalled the game.

I'll post my dxdiag if we run out of ideas but from the looks of it. It's a sound issue at the very least.

0

To confirm the diagnosis, use the /nosound switch in your command line - this will disable all sound - and confirm if it's a sound issue that's causing the crashing. Another source of possible sound issues is the additional audio devices that get sometimes get installed with various devices (ie. - monitors with speakers in them, discrete sound cards). Review your audio devices - and disable any that you don't use - or cannot identify - essentially insuring that only your speaker system and/or your headset - are the only ones enabled. We have often seen surround sound headsets cause this issue.

0

Alright. Deleting the music files in the game folder seemed to fix the issue. Was able to get a 2 hour game in and finish it. Thank you everyone for the help.

0

You could also set the volume for music to 0. this would also stop the music from playing.
(its disabled with 0 volume set)

but nice to hear thats working now 🙂

0

@AnOfficeStapler said in Game freezes and Crashes in FaF singleplayer and multiplayer 100% of the time within 10-50 minutes.:

Deleting the music files in the game folder seemed to fix the issue.

Which files did you delete exactly? I seem to have the same problem (game freezes on exiting and sometimes crashes while playing/watching) and couldn't fix it with drivers. It's a fresh install of Windows anyway; only a few hours old.

Disabling all audio devices prevents the crashes.
Removing the whole "sounds" folder also prevents the crashes.
Playing FA without any audio isn't that much fun though. 🙂

Setting music volume to 0 does not prevent the crashes for me.

0

OH. MY. GOD.

I actually found a solution.

After countless hours of trial and error.
After trying every conceivable sound setting.
After trying various audio devices and configurations.
After restoring to restore points.
After reinstalling every single driver.
After reinstalling every piece of software involved.
After reinstalling Windows.
After reading basically half of the internet.

And the solution for me was.... don't run Forged Alliance from the C drive (which is a fast internal SSD).

Yes, I'm serious. It IS an audio issue though; the crashes happen in xactengine2_9.dll and the FA log clearly shows the XACT audio errors. But moving the Forged Alliance directory to an external SSD fixed the issues.

Not sure if it's because the internal SSD is too fast (resulting in a timing problem) or because it's the boot drive or because something else entirely.

0

There's a simpler answer.

Don't run 5.1 sound. SCFA is, and has always been, notoriously unstable with 5.1 sound. It MUST be run in Stereo or it will crash randomly almost 100% of the time. There is no setting, no magic device, no driver or piece of software that will fix that. It has nothing to do with your C drive. If your log file is throwing repeated XACT messages, over and over - then you are running your sound in some form of surround mode.

It is, quite certainly, an audio issue, with the game.

0

I don't care if you believe me; it's completely reproducible so I KNOW that's what worked for me, even if it goes against everything I know about software development (which is a considerable amount). 🙂

Changing sound settings didn't help at all. I had it set to Stereo, 16bit, 44.1khz, all effects disabled, spatial sound disabled...no dice. Even connected some audio devices that only support stereo (and disabled/uninstalled all others). Didn't help either.

I wish we had access to FA's source code; I'm fairly sure we could fix a lot of things.

Weirdly enough, while others found the same solution (https://steamcommunity.com/app/9420/discussions/0/1620600279663590987/), for some people the problem was fixed by moving Forged Alliance TO the boot volume (https://steamcommunity.com/app/9420/discussions/0/1473096694446040381/).

Log in to reply