Game freezes without warning randomly

0

You wouldn't happen to have a Nvidia GPU and old drivers?

0

@giebmasse I have a GT 1030, and as far as I know my drivers are up to date. I'll check again.

0

@giebmasse They weren't quite up to date, I updated them. I'll try to play a round again.

0

@giebmasse So, I tried again, got a bit further into the round this time, 7 minutes. Froze after I tried to zoom out. It's still happening. I am running FA on compatibility, Vista service pack 2, and classic stereo.

0

Does it happen when you play Forged Alliance itself, running the original game from Steam or Gog Launcher?

0

@scout_more_often Yes, I, among other reasons, bought the game to hopefully fix the freezing that was also occuring on the GOG version. I also had an old version burned to a disc, but all of them would have the same issue.

0

Does it work without all the mods?

0

@magge No, as far as I know it's not related to the mods.

0

Could you double-check that, please, and post a new log without any mod activated to verify it is the same error?

Also, install Supreme Commander fresh and verify it - looks like it could be related to some malformed files as well.

0

Also run in windowed mode unless you are doing so already.

0

And run Furmark and see if the poor 1030 lives through that.

1030 is more or less designed 'to get an image'. Playing actual games on it...

0

@jcvjcvjcvjcv Well, the GPU survived Furmark. I'm going to remove all the mods now and run in windowed and see if anything changes.

0

@magge Well, I tried again without any mods, windowed mode, vista service pack 2 compatibility and stereo. I don't know what's happening.
game_17532825.log

1

So it looks like it was up to the unit icons. I've found a temporary fix: enabling the option in the settings for the unit icons to be constantly loaded. Now there are no crashes, I've been able to play for over 30 minutes now.