Playing the campaign


@deusimperator I apologize if I wasn't too clear, I'll provide a visual guide.

Begin with going to your FAF folder. If you are lost, open the FAF client, click on the 'hamburger' button (I put a 1 there for clarity), then click on 'Show data folder'.


This will open explorer and highlight the FAF folder-open it.


Proceed to the bin folder.


Right click on the faf exe, then click on create shortcut.


This will now create a shortcut to FAF to play offline-you can move this anywhere you want (for example on the desktop). Either way, if you now want to play the coop maps offline, you'll need to edit this shortcut, so right click on it and select Properties.


Add /init init_coop.lua to the end of the target like so:


That's it! You can now play downloaded coop maps by opening the game from this shortcut and going into skirmish, where you'll be able to choose the map, faction, options, and whatever else you want.

As an aside, while you do start these maps from skirmish, you actually load the saves from campaign-it's a bit weird but not too much of a problem at the end of the day.


Got it, thank you! That worked perfectly. I can now enjoy my digital violence in my preferred form :). Thanks again for your help.


So I finally had the time to try this, and it seems that it still freezes in the first cutscene. So far as I can tell I followed the instructions. The only oddity I noticed was that there were only two maps available in skirmish mode: Black Day and Overlord. Can anyone help?


client->play->coop->select any mission there from the available ones

queuing with a newbie to show him the beauty of tmm and meeting tagada be like:


@deusimperator I have tested black day and it can be finished in one sitting with no issues, however, I then tried saving and loading and it will break the objectives, so it will get stuck at the next checkpoint/cutscene as you mentioned.

If you are unable to progress in one sitting, there might be something wrong on your end-make sure you are using the latest version of the coop map from the client.

To check, go to the FAF map folder:


Enter the highlighted folder:


Look for x1ca_coop_001.vxxxx


If you see v0027, that's already the last one. Make sure you don't have other ones around in the folder as you might pick an older one by mistake (manually delete or move those folders somewhere else if you want to keep them).

Again, you should be able to complete this map in one sitting, as I have tested it.

As an aside, when launching the client offline, you will only see the coop maps you downloaded from the FAF client beforehand.


Alright, thanks for your help. I appreciate it.


@deletethis Hi, I just did all things to play campaign, but when I added shortcut with " /init init_coop.lua" game doesnt work:
Moreover I cant see campaign maps in skirmish option, but I downloaded maps for campaign


Hi, it would be better to open your own thread, but I'll try to help you.

Is this the first time you attempt this or did it work before?

Does it work if you launch the coop map from the FAF launcher?

Did you copy paste the string?

Do you actually have init_coop.lua in the bin folder?


That's what comes to mind at the moment, if you can, share more info.


Firts of all I am newbe, I just installed game and FAF client one day ago, and I wanted to do everything at once..

Ok, so I dont know whats happened, but I finally opened the game from shortcut. Maybe because of I tried open coop game by FAF client.

So I opened the game, I can play offline, but I do not see maps which I installed.

I have a lot of maps downloanded, but I cant play on them.
In online mode maps are avaliable.

And now I can see that not every mods works in FAF game.
When I clicked "reload again" in mods options in FAF client, only these three mods are marked.


When using the shortcut with /init init_coop.lua, you will ONLY see the coop maps installed: that's working as expected.
If you want to play regular maps, make a normal shortcut or just launch the exe normally.

As for the mods, check the change logs: latest version deprecated those two, see the thread for more info.