Wyvern Battle Pack v5 for all game versions

Hello fenixthorn,

sorry but the original author is no longer supporting this mod.

I am only a maintainer of this mod and i try to keep it alive as it is.
So i only fix bugs but i don't change the mod for other reasons.

Is this not in the vault?

The cybran t3 tank eviction artillery should have a turret. The reason why is because without a turret it can barely hit anything.


the Eviction is not meant to track vehicles and shoot at it.
Its made for groundattack.

Select the Eviction and use groundfire between you and the enemy.
This creates a nice defensive wall of missiles and explosions.


Just to let you know that the Universal Colossus for Aeon will suck in other land expermentals and armoured command units with it's tractor beam things instanly killing them. Just wanted to report that as i'm assuming it's a bug.

FAF game patch - 3744
Not using any other mods

Tried to upload a screenshot but there is a file size limit.

That sounds like an unintended* consequence of the changes to the tractor beam of the colossus. Checking whether a target is valid is moved away from the weapon class, and to the weapon blueprint. The weapon blueprint of this alternative colossus needs these restrictions set: https://github.com/FAForever/fa/blob/828a358ec66ede492ea516c87a0d7461a3ed7949/units/UAL0401/UAL0401_unit.bp#L439

edit: bet it looks extremely comical though

A work of art is never finished, merely abandoned

@jip Yes it looks hilarious sucking in a unit thats twice the size of the Universal Colossus epecially since the unit physics goes haywire.

Thank you for reporting the bug.
Will be fixed in the next update (which is coming in 2 minutes)

Thanks for leading me to the right place.
This made the bugfix very easy, I appreciate that.

Update 02.Oct.2022 (v5)

  • Unit wsa0306 (Heavy Air Transport) Added missing transport capacity variable (Class1Capacity = 32,)
  • Unit wrl0207 (Mobile Shield Generator) Deleted StandUpright = true,
  • Unit wrl2466 (Experimental Fortress Megabot) Deleted StandUpright = true,
  • Unit wrl0404 (Experimental Prototype Spiderbot) Deleted StandUpright = true,
  • Unit wrl1466 (Experimental Fortress Megabot) Deleted StandUpright = true,
  • Unit wsl0403 (Experimental Tank) Added "HOVER" to Categories.
  • Unit wal0309 (Mobile AA Tank) Added "HOVER" to Categories.
  • Unit wra0305 (Advanced Multipurpose Fighter) changed collision sphere for better beam weapons functionality
  • Unit wsa0201 (Combat Fighter) changed collision sphere for better beam weapons functionality
  • Unit wra0202 (Combat Interceptor) changed collision sphere for better beam weapons functionality
  • Unit ual0401 (Universal Colossus) fixed Tractor Claw; disallow targets: Ships, SACUs and Experimentals

The Megalith MK2 seems to not have any animations or particles.

Nice work on keeping the mods maintained Uveso.

Small bug report for you. The UEF - EXPERIMENTAL - NAVAL : Ultimina Class - (Experimental Battlecruiser) has issues hitting targets with 1 of it's weapons in particular. It seems to fire a little too high and ends up missing the target.

I saw this MOD on the MODDB website that seems to remake ACU? Where can I find these changes to the ACU? Or these changes to ACU have been abandoned and cannot be played


hi, i am busy at the moment, just writing that i saw it 🙂
I don't have any ACU models in my version, but i will download the one from moddb and check it there also.

@uveso Thank you for your work! I only see images on moddb and am not sure if the author included them. Maybe these are in a previous version?

As far as I know these new/changed ACUs haven't been Released by the Creator and are Not included in any Version of this Mod. The Moddb Page itself hasen't been updated since 8 Years and an official GitHub Repository doesn't exists as Well. That means the choices to get them are highly unlikly because the Project seems to be Dead unfortunately.

This post is deleted!


Thanks for the info!

For some reason I can't download the mod from the topic and I can't find it on the FaF Launcher... any ideas why ?
Thanks for keeping the mod updated and worked on

@morgul I had a similar issue & that was a result of setting my browser to enforce using HTTPS-Only mode, so you may need to look into if your browser is setup similarly & make an exception accordingly.

@mostlostnoob You were right, thank you !