BlackOpsFAF-Unleashed only for FAF v24

This is BlackOps Unleashed version 24 for FAF game versions. Tested with (FAF)1.5.3652+

BlackOpsFAF-Unleashed <only for FAF> v24
DownloadSize: 97 MB, Unpacked: 269 MB

Special Thanks to:

Author: Exavier Macbeth, Lt_hawkeye, orangeknight

How to install:

Unrar the archive.

First copy the "BlackOpsFAF-Unleashed" folder from inside the Mods directory to:

C:\...User...\My Games\Gas Powered games\Supreme Commander Forged Alliance\Mods\

This Mod modifies or adds the following 44 buildings, 22 Units and 10 Experimentals to the game:

UEF Buildings:
UEF - TECH1 - LAND : Refuel & Repair - (Light Air Staging Facility)
UEF - TECH2 - LAND : HCPP - X2000 - (Hydrocarbon Power Plant)
UEF - TECH2 - LAND : ATF-205 Preventer - (Anti-Teleport Field Tower)
UEF - TECH2 - LAND : Hellstorm Emplacement - (Rapid Fire Howitzer)
UEF - TECH3 - LAND : ATF-305 Preventer - (Anti-Teleport Field Tower)
UEF - TECH3 - LAND : HCPP - X3000 - (Hydrocarbon Power Plant)
UEF - TECH3 - LAND : Naval Yard - (Advanced Air Staging Facility)
UEF - TECH3 - LAND : Atlas - (Mass & Energy Storage)

UEF Units build by factory:
UEF - TECH1 - LAND : TH-104 Avenger - (Tank Hunter/Mobile PD)
UEF - TECH2 - LAND : Inferno - (FlameThrower Vehicle)
UEF - TECH3 - LAND : Rapier - (Artillery Support Bot)
UEF - TECH3 - LAND : Juggernaut - (Battle Station)

UEF Experimentals:
UEF - EXPERIMENTAL - LAND : Goliath MKII - (Experimental Assault Bot)
UEF - EXPERIMENTAL - AIR : Citadel MKII - (Experimental Aerial Fortress)
UEF - EXPERIMENTAL - NAVAL : Conquest Class - (Experimental Dreadnaught)

CYBRAN Buildings:
CYBRAN - TECH1 - LAND : Ina - (Light Air Staging Facility)
CYBRAN - TECH2 - LAND : Mist - (Anti-Teleport Tower)
CYBRAN - TECH2 - LAND : HC-3 - (Hydrocarbon Power Plant)
CYBRAN - TECH2 - LAND : Squal - (Hailfire Artillery Installation)
CYBRAN - TECH3 - LAND : Manticore - (Heavy Point Defense)
CYBRAN - TECH3 - LAND : Shroud - (Anti-Teleport Tower)
CYBRAN - TECH3 - LAND : ED5 - (Shield Generator)
CYBRAN - TECH3 - LAND : HC-3 - (Hydrocarbon Power Plant)
CYBRAN - TECH3 - LAND : Shadow - (Cloak Field Generator)
CYBRAN - TECH3 - LAND : Naval Staging yard - (Advanced Air Staging Facility)
CYBRAN - TECH3 - LAND : Stain - (Mass & Energy Storage)
CYBRAN - TECH3 - LAND : Winker - (Drone Station)

CYBRAN Units build by factory:
CYBRAN - TECH1 - LAND : Hydra - (Multi-Weapon Assault Bot)
CYBRAN - TECH2 - LAND : Scorpion - (Ambush Bot)
CYBRAN - TECH3 - LAND : Hailfire - (Mobile Rocket Artillery)
CYBRAN - TECH3 - AIR : Vanisher - (T3 Air Transport)
CYBRAN - TECH3 - NAVAL : Leviathan - (Assault Submarine)
CYBRAN - TECH3 - NAVAL : Reaper Class - (Escort Ship)

CYBRAN Experimentals:
CYBRAN - EXPERIMENTAL - LAND : Basilisk - (Ultra Heavy Assault Mech)
CYBRAN - EXPERIMENTAL - AIR : Gargantuan - (Experimental Assault Transport)
CYBRAN - EXPERIMENTAL - NAVAL : SeaDragon MKII Class - (Experimental Dreadnaught)

AEON Buildings:
AEON - TECH1 - LAND : Enclave - (Light Staging Facility)
AEON - TECH2 - LAND : Quantum Wake Generator - (Anti-Teleport Generator)
AEON - TECH2 - LAND : HC-2 - (Hydrocarbon Power Plant)
AEON - TECH2 - LAND : Archangel - (Energy Mortar Emplacement)
AEON - TECH3 - LAND : HC-3 - (Hydrocarbon Power Plant)
AEON - TECH3 - LAND : Purger - (Tactical Missile Defense)
AEON - TECH3 - LAND : Purifier - (Tactical Missile Launcher)
AEON - TECH3 - LAND : Aria - (Heavy Point Defense)
AEON - TECH3 - LAND : Vajun - (Mass & Energy Storage)
AEON - TECH3 - LAND : Quantum Wake Generator - (Anti-Teleport Generator)
AEON - TECH3 - LAND : Sanctuary - (Advanced Air Staging Facility)
AEON - EXPERIMENTAL - LAND : Artemis Control Center - (Artemis Satelite Control)

AEON Units build by factory:
AEON - TECH1 - LAND : Requiem - (Light Sniper Bot)
AEON - TECH1 - AIR : Artemis - (Experimental Satellite)
AEON - TECH2 - LAND : Zealot - (Medium Assault Tank)
AEON - TECH3 - LAND : Wraith - (Heavy Hover Tank)
AEON - TECH3 - AIR : Illuminate - (T3 Air Transport)

AEON Experimentals:
AEON - EXPERIMENTAL - LAND : Genesis - (Experimental Assault Tank)
AEON - EXPERIMENTAL - LAND : Inquisitor - (Experimental Siege Weapon)

SERAPHIM Buildings:
SERAPHIM - TECH1 - LAND : Iasuhthe - (Light Air Staging Beacon)
SERAPHIM - TECH2 - LAND : Uya-atoh - (Hydrocarbon Power Plant)
SERAPHIM - TECH2 - LAND : Haazthue-Uhthena - (Anti-Teleport Tower)
SERAPHIM - TECH2 - LAND : Au-iya - (Restoration Field Generator)
SERAPHIM - TECH2 - LAND : HethIor-Azsa - (Land Mine Dispenser)
SERAPHIM - TECH3 - LAND : Iathuum-Hovathu - (Advanced Air Staging Beacon)
SERAPHIM - TECH3 - LAND : Orba - (Mass & Energy Storage)
SERAPHIM - TECH3 - LAND : Uttauthuum - (Heavy Point Defense)
SERAPHIM - TECH3 - LAND : Haazthue-Uhthena - (Anti-Teleport Tower)
SERAPHIM - TECH3 - LAND : Uya-atoh - (Hydrocarbon Power Plant)
SERAPHIM - EXPERIMENTAL - LAND : Uttaus-Athellu - (Lambda Field Generator/Advanced Point Defense)
SERAPHIM - EXPERIMENTAL - LAND : Haasioz-Iya - (Seraphim Quantum Rift Archway)

SERAPHIM Units build by factory:
SERAPHIM - TECH1 - LAND : Ilhaas - (Protector bot)
SERAPHIM - TECH2 - NAVAL : Zthuzene - (Bombardment Ship)
SERAPHIM - TECH3 - LAND : Ilthysathuum - (Lambda Equipped Assault Bot)
SERAPHIM - TECH3 - AIR : Vulthatha-Ioz - (Missile Gunship)
SERAPHIM - TECH3 - AIR : Vishathal-Atah - (Tech3 Air Transport)
SERAPHIM - TECH3 - NAVAL : Ithaluthe-Esel - (Heavy Cruiser)

SERAPHIM Experimentals:
SERAPHIM - TECH1 - AIR : Winker - (Repair Drone)
SERAPHIM - EXPERIMENTAL - LAND : Yenzotha - (Experimental Hover Tank)
SERAPHIM - EXPERIMENTAL - NAVAL : Hovatha-Hauthu - (Experimental Dreadnought)

Update 21.Aug.2023 (v24)

  • fixed some issues with drones
  • fixed an issue where hydrocarbon power plants are not buildable by tech1 engineers

Update 05.May.2023 (v23)

  • fixed a incompatibility with BrewLAN (Thanks to Balthazar)
  • fixed a bug in case a air weapon has no RangeCategory UWRC_AntiAir

Update 03.May.2023 (v22)

  • fixed a incompatibility with BrewLAN (missing SizeZ on units)

Update 22.Dec.2020 (v19)

  • Unit UAA0310 Added VeteranMassMult = 0.5, to blueprint for propper veterancy calculation
  • Unit UAS0401 Added VeteranMassMult = 0.5, to blueprint for propper veterancy calculation
  • Unit BAA0309 Added TeleportDelay = 10, to blueprint to match FAF patch
  • Unit BSB4209 Added TeleportDelay = 10, to blueprint to match FAF patch

Hi Uveso. please tell me can i run it on vanilla? Or a lot of problems? I can edit the files if necessary. I tried to run a vanilla mod in a campaign but the scripts do not run = (

Hello Divangel ,

no, sorry. The FAF version of the Black ops mod does not run outside of FAF.

There are many places where we patched the mod to get the latest FAF updates and changes included.
So we refactored almost every script and blueprint.

If you want to play Black ops on vanilla you need to use the old mod version:

BlackOpsACUs V10

BlackOpsUnleashed V10

BlackOpsEXUnits V4.1 (BlackOps Special Weapons)

BlackopsSupport V6.2 (Global icon support mod)

greetings, Uveso.

@Uveso Understood and accepted. Well, at least there is version 10, and it has clearly changed something.

The old Black Ops mods version 10 are from my personal archive, last change was 21.08.2016
Its the latest version for Vanilla/Steam that exist.

Don't forget to check my updated-mod post. Most mods are compatible with FAF & Vanilla:

@Uveso Perhaps it will be out of topic. but it's hard for me to search for anything since my native language is not English. What I was afraid of FAF was installed in the C : program date. What for? do you know how to change the folder? To install on other disks

You can't change the ProgramData folder as far as i know.

Its the same folder like we had in Windows Xp C:\Documents and Settings\All Users\Application Data\
The folder position was moved, in newer windows versions, to the root directory.

@Uveso OK my friend. I studied the FAF and realized that it was not mine. It is tailored for multiplayer and I like to build a base for 3 hours long and hard =). And you can't save the game that's bad. I have not received such good feedback thanks.

No, you don't need to play multiplayer at all.
Only use the FAF client to update your game.

To start the game, don't start the FAF client, just start the .exe in

Create a desctop shortcut and you can start the FAF version of the game like the normal vanilla game.

@Uveso Well, if I move the game folder to another location, will it work?
C : \ ProgramData \ this is a bad place, on this ssd disk of windows, it does not need any external applications

This is what microsoft says:

Have in mind we can't help you if you change the folder and something went wrong.
(Windows updates, fixes, or service packs will no longer work)


@uveso I'm not sure what you guys did in recent patches (3721+), but any unit using the Railgun01 projectile is borked. The particle effect won't go away, and it builds up in the sim, and lags the whole game. My last LAN game had the Citadel in it (via MCP, but I confirmed the problem on regular BlackOps game, too), and I had to constantly run the "Purge Projectiles" command in any attempt to try to finish the game.

Do you know of any short workaround outside of the obvious (banning units, etc)?10.jpg

oh no - this is something we did. If I am correct the unit is the Citadel and it is part of Marlo's Compilation Pack?

A work of art is never finished, merely abandoned

@jip As implied, the unit is originally from the BlackOps line of mods. Yes, it is the Citadel MK II.

The unitpack, I'm talking about where I noticed the issue from, is Mixed Combat Pack (MCP): . MCP mixes together popular units, of various untipacks, and bugfixes/rebalances them together for one mod (TotalMayhem is notorious for having more powerful units vs. vanilla). My main interest in the mod is the backbone programming work he did, and notsomuch it being a convenient unitpack in one mod.

I did check over the BP file of his version of the Citadel, and it's fine. Here's a Winmerge report showing the differences: Citidel differences.7z . The left column is basically Uveso's BO release, and the right column is from MCP. The differences are just unit stats, and sourcing to make the unit work in his mod. And yes, I did follow-up on the Railgun01 files, and didn't see any differences there over Uveso's BO release.

I also mentioned running my standard mod array testing this (this doesn't include MCP - I only recently discovered it this past week). I ran a sandbox game, and this is where the screenshot came from. All those projectiles are "stuck".

I will see if any of my other mods are interfering with this, but I'm raising doubts. When I ran MCP, for my LAN session, the only other stuff running was basically QOL stuff. This seems to be something caused by the recent patches. I don't recall seeing this issue, beforehand, with the Citadel.

I'm quite confident that this is related to the patch and not mod interference. I'll investigate right away 🙂

A work of art is never finished, merely abandoned

@jip Considering I know little about the FAF integration level, so, this is appreciated. The sooner a hotfix goes out, the happier I'll be.

All that I know is that the Railgun01 projectile isn't native to Supcom, and it's borked on units that use it.

@Xathos I have this scenario:


But it doesn't cause any issues. Could you reproduce the issue with 1 unit, fire one, and then show me the content of your game log? Nevermind, it is the AA gun:

WARNING: Error running OnImpact script in Entity /projectiles/tdfheavyplasmagatlingcannon01/tdfheavyplasmagatlingcannon01_proj.bp at 1bf7ad80: 0 radius specified.
         stack traceback:
         	[C]: in function `DamageArea'
         	...velop\supreme-commander\fa\lua\terranprojectiles.lua(863): in function <...velop\supreme-commander\fa\lua\terranprojectiles.lua:858>

It has to do with this, and therefore it has to do with the patch.

    OnImpact = function(self, targetType, targetEntity)
        local pos = self:GetPosition()
        local radius = self.DamageData.DamageRadius
        local FriendlyFire = self.DamageData.DamageFriendly and radius ~=0
        DamageArea( self, pos, radius, 1, 'Force', FriendlyFire )
        DamageArea( self, pos, radius, 1, 'Force', FriendlyFire )

        self.DamageData.DamageAmount = self.DamageData.DamageAmount - 2
        if targetType ~= 'Shield' and targetType ~= 'Water' and targetType ~= 'Air' and targetType ~= 'UnitAir' and targetType ~= 'Projectile' and targetType ~= 'Unit' then
            local rotation = RandomFloat(0,2*math.pi)
            local army = self.Army
            CreateDecal(pos, rotation, 'scorch_001_albedo', '', 'Albedo', radius, radius, 70, 30, army)
        MultiPolyTrailProjectile.OnImpact(self, targetType, targetEntity)

The issue is that we do not check the radius here - we expect that to be something else than 0. I'm going to discuss with Keyser whether this is something we should fix, or whether it is the mod that should fix it.

A work of art is never finished, merely abandoned

@uveso so why is v18 still in the Vault, should it not be this one?

this should be fixed inside FAF.

Adding "DamageRadius = 1," inside modded unit blueprints does not work (still outputs 0 as radius)
self.DamageData.DamageRadius or 1` is also not working because the DamageData defaults the radius to 0 when its not existend.

Kind of funny:

        local FriendlyFire = self.DamageData.DamageFriendly and radius ~=0
        DamageArea( self, pos, radius, 1, 'Force', FriendlyFire )

FriendlyFire is only true if radius is not 0, and the function crashes when radius is 0. Nice ^^

Are you talking about Black Ops ACU v18 or Black Ops Unleashed V19 ?