AI-Uveso (v108) - AI mod for FAForever

0

@swaaye said in AI-Uveso (v108) - AI mod for FAForever:

Has anyone noticed that the civilians won't attack the Uveso AI? I think this is new behavior though I don't know what may have caused it.

No, i did not noticed this, and there is no code/function for civilians in the AI-uveso mod.
We will take a look at it. Thanks for reporting!

0

On some naval maps the AI just builds T1 subs until it hits unit cap. This is especially true if there's a section of water where the subs are trapped. Is there any way to avoid this? In this game 30% of unit cap is taken by T1 subs at 25 minutes: https://imgur.com/W5Ytb01.

Also, does disabling nukes prevent the AI from working properly? I posted a year or so back and you fixed it. Recently it seems like disabling nukes makes the AI stop building most experimentals. UEF seems most affected by this change. Aeon plays normally with nukes off.

1

@bsee

Thank you for your report again!

I'm very busy at the moment but I've put it on my todo list.

not sure why so many subs are build, normaly the builder should not overbuild.
I guess i forgot to add a buildcondition to check for enemies.

And yes, the AI needs to have nuke/antinuke to continue with higher tier units like experimentals.
I will have a look at it and see if i can use a different build logic without nukes.

0

@uveso

In a similar vein to the sub glitch, I've had several games where a tight match is thrown by the AI building absolutely nothing but T2 AA units. Hundreds of them.

0

@tankmayvin

Thanks for reporting.
This should be fixed in the next version.

1

Is it possible this mod prevents the score screen from showing for all players at the end of the game? We played a couple very short games to narrow down the issue. With AI Uveso only one player gets the score (usually the host). Without the mod all players get the score. This has been an issue for a long time, but only just now narrowed it down to this mod.

No mods: https://replay.faforever.com/18954136 - Everyone got the score
AI Uveso: https://replay.faforever.com/18954020 - Host got the score

0

@bsee

Thanks for reporting!

i will check and fix it. 🙂

2

@bsee

i guess i found the bug, it should be fixed in v109 (release maybe next weekend)

0

@uveso I looked at the problem with the civilians not attacking the AI again and it does seem to be specific to the Uveso AI. I disabled all other mods and tried a couple maps with civilians. Purely default FAF with just Sorian AI has the civilians attacking everyone correctly. Adding the Uveso AI mod and Uveso AI does not get attacked.

0

@swaaye said in AI-Uveso (v108) - AI mod for FAForever:

@uveso I looked at the problem with the civilians not attacking the AI again and it does seem to be specific to the Uveso AI. I disabled all other mods and tried a couple maps with civilians. Purely default FAF with just Sorian AI has the civilians attacking everyone correctly. Adding the Uveso AI mod and Uveso AI does not get attacked.

well that is strange.
First thing I can say, I don't have any special function in my AI to deal with civilians.
Will get into it and see what happens there.

Thanks for reporting the issue!