Every Replay crashes (and many games)

Thank you guys, I will give it a try! Weird though, that it is related to replay speed.. FYI: I also recall no recent updates of my sound driver, that could be related to the point in time at which this issue emerged.

Be aware, Microsoft updates have routinely, over the years, turned their own surround sound settings, back on - and reverted audio hardware from Stereo to Surround, on more than one occasion.

Also, Nvidia comes with their own sound, NVIDIA High Definition Audio. And they install it every time with their updates...

Good point, my monitors have integrated speakers as well that are handled by the nvidia drivers.

Nothing worked so far, I disabled all my audio devices and checked all surround settings. Any furhter advice? It has become very unbareable lately, because most of the games crash as well!

Have you yet tried to use the command line switch /nosound - this will confirm if your issue is sound related or not. Yes - it does exactly what it implies - disables ALL Sound, but, for the purpose of the test, it will definitively prove if it is the issue.

@sprouto Thank you! That did the trick, as far as I can tell. No more crashes on replays that crash 100% otherwise. Now the question remains: what can be done about it?

If you think it is an isolated problem on my machine, I can try some more stuff. Just FYI: I do not have troubles on any other game or piece of software, and the problems, at least in my impression, emerged with one of the former patches or client updates.


Unfortunately, supcom is pretty finicky and if you can't use the exact settings pointed out in the audio FAQs by ensuring that only those Windows settings are applied, there isn't much to do.

Make sure that no other drivers or programs related to audio are in use, and try using other speakers or headsets: some of them have their own integrated audio drivers that will add effects or other things which supcom won't like.

Try just plugging the most basic speakers/headphones you can find directly into the motherboard left/right/headphone port (typically it's the green one) to exclude a hardware issue.

The more information you can give, the more help you'll get.

You can try different sound drivers:


Those are 100% working with Supreme Commander. If you still have any problems, then you need to go a long route to solve it. Uninstalling any 3rd party sound software/driver and any running related services. And last resort, a fresh Windows installation with default settings.

Thank you all for your help, @magge, @deletethis, @Sprouto, @Zokora and @arma473. I will play around once more with my sound settings, config, etc.. Should anything useful appear, I will let you know.