Serious issues with new update, please revert.

0

First, I want to thank everyone for their hard work while not being paid to keep faf alive. This is excellent.

What is not excellent is my experience with the patch so far. I am having numerous problems that are ruining my ability to play this game anymore.

  1. shift-queued orders for engineers are dropping about half the time. I will queue up a series of events such as build these mexes -> hydro -> mexes -> fact

They input, I see them, then they vanish a few seconds later. My engies completely forget everything given to them.

This is not limited to only individual units, but also factories. I have in one game told a factory to build a unit 5 - 10 times only to have the factory cease building a few seconds later.

I haven't changed how I input commands. I have changed nothing. This was not an issue before this update. Now it happens every game.

  1. I will do something simple such as ctrl k a mex and try and select a t3 eng that has adjoining t1 engies to build a t3 mex in its place. I can't select the t3 eng half the time anymore, instead my mouse grabs a yellow marker and drags that but never selects the engie. The only solution is to try and click over and over until it works. It feels as if I'm trying to grab butter with greased fingers.

I have done this thousands of times in the past. Before this update this was never a problem.

  1. Strange things such as I tell a CMDR to upgrade to t2 -> t3, then a few moments later I will have selected another unit and a walk command will be issued to the CMDR breaking the upgrade. In the past this would not happen. You could not make an upgrading CMDR break the upgrade by issuing a move command. But this is happening now. I am also seeing this happen with factories. I will have one upgrading from t2 to t3 and suddenly it will stop upgrading.

To me it seems as if there's something broken on the input layer that is carrying over commands from other events and jumbling them with others. I'm not a developer anymore, I haven't written code in fifteen or more years, so I leave this to the developers of faf to figure this out.

  1. Other strange things such as I'll have units assigned to assist the CMDR. I will then tell the CMDR to start building something. While the t3 pgen is building, for example, in the past I might tell the CMDR to move to upgrade a mex or something else, leaving t1 engies making the pgen. They would continue to do this. Now, in this update, they might randomly stop building the t3 pgen before completion and move back to the CMDR to start assisting again.

This makes no sense.

  1. I may have a group of engies assigned to assist a t2 mex to upgrade to t3 and then make storages. In the past they would all do this, then move to the next mex in the queue. Now, I am finding that three or four may start the storages while the rest leave and move to the next mex, as if some mystical force is directing them to stop doing what I told them to.

I don't know what's been changed, but the behavior of my game has changed greatly since the latest development version was pushed to live.

Please help.

Thank you.

mods I use:

Supreme Scoreboard
Advanced Attack Priorities 1.1
Spread Move
Nvidia Fix
Penguin's Icon Mod

1

Did you make sure all the UI mods are turned off when making these observations?

A work of art is never finished, merely abandoned

0

@jip First post edited to list mods I use. I don't think any of these would cause a problem?

Nvidia fix can probably be removed now?

0

Yes - nvidia fix is no longer required if your drivers are recent.

A work of art is never finished, merely abandoned

1

Probably start by disabling the new feature that automatically selects to build a mex when you mouse over a mass point. That's the first thing I did when I installed the patch. Pretty abusive to create random new UI quirks and then enable them by default for everyone.

1

Are other people experiencing similar issues? Can they post replays + timestamps where this happens?

I can not reproduce everything that you are describing - I'm not saying I don't believe you. Just stating I can't reproduce it reliably.

Other strange things such as I'll have units assigned to assist the CMDR. I will then tell the CMDR to start building something. While the t3 pgen is building, for example, in the past I might tell the CMDR to move to upgrade a mex or something else, leaving t1 engies making the pgen. They would continue to do this. Now, in this update, they might randomly stop building the t3 pgen before completion and move back to the CMDR to start assisting again.

I can't reproduce this using a t3 engineer with 50 t1 engineers assisting. I can't reproduce this with a commander either. Can you show a replay + timestamp where this happens?

cbb7d02a-5c6a-4452-b02e-1389eeefc8dd-image.png

I may have a group of engies assigned to assist a t2 mex to upgrade to t3 and then make storages. In the past they would all do this, then move to the next mex in the queue. Now, I am finding that three or four may start the storages while the rest leave and move to the next mex, as if some mystical force is directing them to stop doing what I told them to.

4418aa6b-f9d8-470b-be9b-154e4af4d6cf-image.png

Gotcha - this is what happens I suspect. No idea why yet, but it happens that some engineers skip the storages.

I will do something simple such as ctrl k a mex and try and select a t3 eng that has adjoining t1 engies to build a t3 mex in its place. I can't select the t3 eng half the time anymore, instead my mouse grabs a yellow marker and drags that but never selects the engie. The only solution is to try and click over and over until it works. It feels as if I'm trying to grab butter with greased fingers.

1fb211f1-1f00-4b50-964a-6fc526ba2a06-image.png

I can't reproduce this, do you have a replay + timestamp where you feel this happened?

shift-queued orders for engineers are dropping about half the time. I will queue up a series of events such as build these mexes -> hydro -> mexes -> fact

I can't reproduce this, tried with 5 engineers and 10 different buildings queued up. They all finished as you'd expect. Can you share a replay + timestamp when you feel this happens?

Strange things such as I tell a CMDR to upgrade to t2 -> t3, then a few moments later I will have selected another unit and a walk command will be issued to the CMDR breaking the upgrade. In the past this would not happen. You could not make an upgrading CMDR break the upgrade by issuing a move command. But this is happening now. I am also seeing this happen with factories. I will have one upgrading from t2 to t3 and suddenly it will stop upgrading.

547617fc-b1bf-4f40-90fe-2f0c21a75923-image.png

I can't reproduce this either - do you have a replay + timestamp?

I can reproduce it by having it part of some set of commands that I shift + g:

145a3362-faa6-419c-8e82-e4a064c24ff5-image.png

The UI even remains on T3, even though I can't build anything with it. Is that the same case for you?

A work of art is never finished, merely abandoned

0

@thomashiatt how do I do this?

0

@mr_blastman said in Serious issues with new update, please revert.:

@thomashiatt how do I do this?

In-game, go to the options menu, then the gameplay tab, then scroll to the bottom of the list and disable the new mex-related option.

@Jip
I believe I've had problems like 4 and 5 from blast's list happen to me as well, but I think they also happened before this most recent patch.

0

At least that adds to the confusion 👍 , anyone else?

A work of art is never finished, merely abandoned

0

i also have issues in 2) - sometimes. i thought it is my mouse - i have replaced(resolder new) left button switch 5 times...

1

@thomashiatt said in Serious issues with new update, please revert.:

the new feature that automatically selects to build a mex when you mouse over a mass point.

I wouldn't mind this feature if it only did that for UNBUILT mexes

It's setting me up to "build" a mex on spots that already have partial- or fully-built mexes on them

So it interferes with selecting mexes to add storages

0

@mr_blastman said in Serious issues with new update, please revert.:

Nvidia fix can probably be removed now?

Yeah, it's been fixed for more than half a year. They plastered it all over the client's frontpage. Kinda hard to miss it.

0

bump, still waiting for replays + timestamps.

A work of art is never finished, merely abandoned

0

@mr_blastman

You might want to try temporarily deleting or moving all of your downloaded mods to another folder (that FA/FAF won't access) and seeing if that resolves your issues. There presently seem to be some bugs that result in certain downloaded UI mods having effects despite not being enabled...

0

@emperor_penguin said in Serious issues with new update, please revert.:

@mr_blastman

You might want to try temporarily deleting or moving all of your downloaded mods to another folder (that FA/FAF won't access) and seeing if that resolves your issues. There presently seem to be some bugs that result in certain downloaded UI mods having effects despite not being enabled...

Only if they use custom textures - if it is anything else, please do share the mod.

A work of art is never finished, merely abandoned

0

Just to bump this topic - I am still waiting for replays where the situations you describe happen.

A work of art is never finished, merely abandoned

1

Since last update scathis does not shoot properly anymore. Needs ca. 1 minute to start shooting

0

@alina-kiss said in Serious issues with new update, please revert.:

Since last update scathis does not shoot properly anymore. Needs ca. 1 minute to start shooting

That was quite literally my mistake 🙂 .

It is fixed and available already on the FAF Develop branch.

A work of art is never finished, merely abandoned

1

@jip Thx, sometimes it happens, but all of you make a really great job.

0

Another crash for all players (all players got the debug window)
game_15448984.log
crash.txt