FAF CLIENT ALWAYS AS ADMIN

0

So I take back what I said:
We are not writing registry even tho I think that would also be a way to determine if one has privileges.
We are using cacls.exe to read the permissions of a file we should not be able to read...
https://docs.microsoft.com/de-de/windows-server/administration/windows-commands/cacls
Screenshot 2021-06-12 142642.png

Soon™️

0

If you open Task Manager under details you can click on the table header and select columns(on right click). You can add a column showing you if a process is elevated(Herraufgestuft in German, my windows is in German).

if the client shows as not elevated but shows the warning. We can have you guys type in a commands in a terminal(cmd) and check what commands work better to determine if you are admin.

Soon™️

0

Screenshot 2021-06-12 144009.png
what it should look like

Soon™️

0

Heraufgestuft = Elevated

Soon™️

0

Btw if you are not using windows 10 that might be the reason... but I am not sure if I would change it for ppl that are not using a OS with support.

Soon™️

0

@axel12 said in FAF CLIENT ALWAYS AS ADMIN:

Btw if you are not using windows 10 that might be the reason... but I am not sure if I would change it for ppl that are not using a OS with support.

So you are deciding how i have to use my PC ?
This is at least interesting if not outrageous.

I stop arguing here since it looks like it depends on your opinion not on support for users.

0

I think it is more that it would be a burden from the development standpoint to try and figure out how to implement detection for a depreciated OS

0

Ehm I offer my help 😄 I don't have to capabilities to decide

Soon™️

0

You miss understood me. I offer to fix it if it should be the case that anybody is using windows 10 and the check is broken.

Soon™️

0

Im not with the error anymore after doing some things to run without admin mode.

Even without error i got to task manager and faf is not on admin mode but it istill creates folder on ProgramData and recreates a mydocuments there where i need to put the mod/maps or it wont show on my launcher.

Im feed up with this i dont need help anymore since my problem was not being able to create a lobby with my mods/maps to play a private games with friends, if i select the mods inside the game everyone was kicked saying they dont have the mods(even when everyone had).

This was caused by this ProgramData folder where i need to put the mods/maps on instead of the real C:\Users\xxx\Documents\etc.

0

Yes this is the case in FAF because Anti Virus often gets mad at the client for editing documents folder so the default now is to use programmdata. Because we had a million complains where client was not able to read/write the folder. There is a setting to turn it back if you want to. Also in the menu you can click open mod folder and it will open the currently set one.

Further you could upload the maps/mods then FAF will take care of installing them.

You can of course suggest other solutions but as far was I am aware there is not much other choices. Writing stuff to documents folder in win 10 is sub optimal as I far as I am aware.

Soon™️

0

A symlink could be discussed but then I think you would load them twice I guess tho 🤔 Unsure if that works

Soon™️

0

Shows you mod folder
Screenshot 2021-06-12 165106.png

Can be turned off to use the documents folder again...
Screenshot 2021-06-12 165045.png

Soon™️

0

Often times Documents folder that the client found was out of sync with the game. But is less hassle if the default is programmdata

Soon™️

0

Thanks didint know of that Vault Fallback Setting i turned it off and the client is looking at my original maps/mods locations so i dont need duplicates on ProgramData(My C is a small SSD only with windows and programs and is almost full).

0

@uveso said in FAF CLIENT ALWAYS AS ADMIN:

@ZLO

The problem here was the fact that many users had access permission errors inside the FAForever folder.
Mostly because they tried to start the FAF client as Admin to solve other problems they had.
But running as admin will write pref and config files with admin rights.
If you now run the client as normal windows user you no longer can change these files and you will get
[13]permission errors in java.

To prevent users from starting the client as admin when they are normal user is the reason for this nag windows.
But when your system only has a single user with admin rights then this message makes no sense.
i can't run the client as normal user and will never get those permission errors...

So for us, this window is just annoying and has no meaning with our window configuration.

The client should look into the windows accounts and only display this message in case there are
admin and user accounts present.
And it should not display it on windows with just 1 user.

Dont agree at all. If you use windows with UAC like every other person, you should never run into this problem (unless there is a bug), and disabling UAC is just a REALLY bad idea in general and not at all recommended, even by windows itself.

Its impossible to check every way in which people misconfigure their system. The client should not need to support all of them, and in my book disabling UAC is a misconfiguration.

0

i have done some attempts to remove this message while having UAC off and was not succesfull... maybe it is easyer to make a special version of cleint.
Or maybe add a setting in client settings to now show this message, i don't think checkbox "do not show again" is good
Because you can easy break all file permissions if you run client as admininistrator and then have no idea why you have issues, and this message is very helpfull in those cases, you don't want to let people hide it just cause it is annoying

TA4Life: "At the very least we are not slaves to the UI" | http://www.youtube.com/user/dimatularus | http://www.twitch.tv/zlo_rd

0

@ZLO

Also a command line parameter would work. Something like this:

"downlords-faf-client.exe /NoAdminCheck"