Linux Support


@usling it worked for me as well! ๐Ÿ˜„


After messing around a bit more, I still can't seem to get rid of the issue where the game will jitter/get stuck on a frame for a bit (but noticably) longer than all the other frames. In other words, the game mostly flows at the right frame rate, with quasi regular frame lag every couple of seconds or so. Any suggestions? Thanks!


ะฝะฐ 32 ะฑะธั‚ะฐ ะฝะตั‚ ะฒะตั€ัะธะธ?


@esthetics of what? I don't know what you're talking about. FA is 32bit.


Hi everyone.

I got few monthes ago a new computer which is best suited to play SupComm : FA.

I installed Steam on my new computer and have no problem to run forged alliance from steam.
But i can't launch a game or a replay from FAF.
I installed FAF and even try the last version recently (1.6). Faf run without any problems, but when i launch a game from the program, i get an error :

java.lang.RuntimeException: Forged Alliance Crashed with exit code 2. See  for more information
	at$$Lambda$2943/ Source)
	at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
	at java.base/java.util.concurrent.ThreadPoolExecutor$ Source)
	at java.base/ Source)

My skills are limited, and i can't find a way to fix that problem.
I was wondering if it's because i installed the Flatpak Steam on my linux mint, instead of the regular one. Anyone use flatpak version of steam ?


Did you launch the steam version and make a profile before launching FAF?

A work of art is never finished, merely abandoned


Yes sir. ๐Ÿ™‚
And copy the "run" file in the good folder.
I changed de path to be the one used by the flatpak version of steam. But maybe i forgot something ?

If you want to see some logs, just tell me which one and how to get it ๐Ÿ™‚

Thanx for your help ๐Ÿ˜ƒ


@zorglub yes it is indeed because you installed the flatpack version of steam. I recommend you delete that and any leftover steam files

(do not attempt to have a flatpak steam simultaneously with a native steam that is a terrible idea)

if you want to avoid redownloding the games you downloaded, you can take the folder in : steam called "common" that is under "steamapps" (if you right-click on the game in the steam library you can open the folder where the game is installed, then by going up one folder you'll have the "common" folder.) you can move that folder to another place, (say Documents) and then delete steam flatpak and install steam as a native.

when you are here : it gives you the right file.

you can run it by right clicking in empty space in the folder you downloaded steam to then selecting "open in terminal" and in the window that pops up, type in :
(I'm assuming you're on Pop_OS, ubuntu, mint, kubuntu, Zorin,... basically debian based. if not and you're on Manjaro or something like that, you'll have to do something else like sudo pacman -S steam )

sudo dpkg -i steam_latest.deb

(you'll need to type in your password)

then follow the steps and then you'll be able to run steam from your start menu.
make sure to enable proton for all games in the options (steam was completely reinstalled so you need to do everything again)

then you can close steam, move your "common" folder to :

then start steam back up and start the download for the games you previously had installed.

steam will recognize the games are already in the right folder and simply "discover" them instead and then they'll be installed.

then you can try again by giving steam the run arguments I talk about in my video
run FA once from steam, go fetch the run file and put it in your FAF install dir and point to that in the FAF options.

and you should be good to go.


Great, you confirm my suspicion.

i'll try what you suggest when I got some time (i'll need to move other games too) ๐Ÿ˜ƒ


@zorglub It really doesn't take long at all. the steam download of itself isn't very long.



I successfully got Downlords client up and working finally, but now that I have I can't seem to get it to work. I keep getting Error Code 2, with the error text below.

(I did have some trouble the past two days trying to stay logged in and even connecting, though that issue seems to have subsided as today it went without a hitch but I'm unable to get past this error)

As always, any assistance would be appreciated.

java.lang.RuntimeException: Forged Alliance Crashed with exit code 2. See  for more information
at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(
at java.base/java.util.concurrent.ThreadPoolExecutor$
at java.base/

Forgive me, I found my mistake. Finally found tatsu's video and found out I needed to point the executible of the run file in the preferences. However, I do have 1 last problem I hope.

I have to start the game in windowed mode. Currently, it runs only in full screen and i only get a black screen with severe lag when moving my mouse from the audio moving over the icons. If i run via steam directly, it uses the /windowed mode just fine, however even after setting windowed mode in the game.pref file (copied and pasted from the windows version that works just fine) It still only opens in full screen.



I am getting the stuck in full screen bug. Is there a fix for it yet?


Hello, I'm having issues launching the client now. Not sure where I'm going wrong. I have the correct JDK installed but I get java errors after the client splash screen closes.

(Edit: Removed log)


@gzack I was able to get past this error by using v2021.10.0, however, I still have a Java exception that occurs during login.

๐Ÿ˜ž I don't like using Java.


FYI the new pre-release has moved to Java 17, so this should be less problematic for Linux users.

"Nerds have a really complicated relationship with change: Change is awesome when WE'RE the ones doing it. As soon as change is coming from outside of us it becomes untrustworthy and it threatens what we think of is the familiar."
โ€“ Benno Rice


@brutus5000 said in Linux Support:

FYI the new pre-release has moved to Java 17, so this should be less problematic for Linux users.

That's great news! Does the development team have a specific distribution of Java 17 that they are targeting? OpenJDK, AdoptOpenJDK, Azul, etc.?


We use the adoptOpen/temurin distribution for the client


Still no luck. I'm not sure what to do at this point. I've tried many versions of the client and of Java. Using Artix and DWM (if that matters).