Linux Support

1

@foodlfg
Thanks. Downgraded proton version in steam to 5.0, and all works. Seams like there is some bugs with 5.13 proton run script.

0

guys that happens if you close steam.

0

Anyone else getting crashes with replays? Pretty much every replay crashes for me at random times, sometimes 10 minutes in to the replay, sometimes 30.

This is with Proton 5.0 and Nvidia 455.38 drivers.

0

no. no replay crashes for me.

proton : 5.13-1
nvidia : 450

it's probably the nvidia 455 driver. that sound a bit too hot off the press.

0

I'm pretty sure I've had the replay crashes for a while now, long before 455 but I've never tried Proton 5.13, let me test with that.

1

@tatsu said in Linux Support:

guys that happens if you close steam.

This is also very weird because with Proton 5.0 and below you never had to have Steam running.

EDIT: This can be fixed by removing "steam.exe" from the last line of your "run" file.

0

OK with Proton 5.13 I have no crashes so far, 40 minutes into a game.

I've also just realized I've been playing with D3D9 all this time! I just switched to D9VK and the game is soo much smoother!

Now, my only remaining issue is all the missing effects but I guess there is no solution to that 😞

0

@callcifer said in Linux Support:

EDIT: This can be fixed by removing "steam.exe" from the last line of your "run" file.

mmhhh TY

@callcifer said in Linux Support:

I just switched to D9VK

how'd you do that?

0

@tatsu said in Linux Support:

guys that happens if you close steam.

no, it is not because of that. as i said:

if i just run the run 5.09 file from terminal the original game launches.
if i run the 5.13 file nothing happens. it is working with launching from Steam, but not from terminal or from the client.

i ran the two files after each other. one worked the other one does not.
if steam had not been running then the first one would not have worked either.

only 5.09, 4.xx run file generates properly for me.
5.13 does not

0

@callcifer
it is hard to test for long games but as for me:

  • Proton 5.09 - 2x long setons games, 2x crashed at 30min
  • Proton 4.11 - tested today with palying a 1+ hour long setons game. worked fine and it worked back then too.

expect crashes. and test for it.
the game is not 100% stable with Wine / Proton.
we dont know why.

1

OK there seems to be some confusion. Here's where I stand.

  • Actual gameplay is stable for me with both 5.0 and 5.13.
  • Replays almost always crash with 5.0 but never with 5.13.

@foodlfg said in Linux Support:

if steam had not been running then the first one would not have worked either.
only 5.09, 4.xx run file generates properly for me.
5.13 does not

This is not correct in my experience. Before 5.13 I never had to have Steam running to play FAF. What has changed with 5.13 is that Steam generates a slightly different run file. With 5.0 and earlier the last line of the file ended with:

bin/wine" "${@:-${DEF_CMD[@]}}"

but with 5.13 it became

bin/wine" steam.exe "${@:-${DEF_CMD[@]}}"

So instead of executing SupremeCommander.exe directly with wine, 5.13 instead calls steam.exe which in turn launches the game. That's why 5.13 doesn't work if Steam isn't running. Still, as I've said, you can fix this very easily by removing steam.exe from that line and everything will work correctly.

@foodlfg said in Linux Support:

the game is not 100% stable with Wine / Proton.
we dont know why.

Again, not in my experience. I've had zero stability issues with Proton 3.16 and 5.13. The only problematic ones for me were 4.11 (caused desyncs) and 5.0 (caused replay crashes).

@tatsu said in Linux Support:

I just switched to D9VK

how'd you do that?

With Proton 5.0 and above Proton defaults to D9VK instead of Wine D3D9 so you don't have to do anything special. If DXVK_HUD=1 shows you the DXVK hud in game then you are using D9VK. Of course, you can try to force enable D9VK with PROTON_USE_D9VK=1

0

oh ok if it's default then perfect.

0

@callcifer
i have a Proton 4.11 run file from june and it already had steam.exe in it.
bin/wine" steam.exe "${@:-${DEF_CMD[@]}}"

so this is not Proton version dependent.
more like Steam version, but even that is unlikely.

and my problem is not "steam is not running" with Proton 5.13.

0

Looks like my setup broke. Everytime I try to join a game I'm stuck with the FA mouse cursor and a black screen. Pinning Proton to 5.0-10 did not help. And I can't tab out of the black fullscreen window... Any advice?

0

If you start it from the terminal do you see any error messages?

Also, if you recently installed any updates make sure to reboot as kernel/driver changes can cause problems until a reboot.

0

@Brutus5000 you could delete .faforever and .com.faforever.client.FafClientApplication in home see if it's not the conf file that's messed up.

if that doesn't do it. regenerate the run file (remove steam.exe like calcifer did)

if that doesn't do it redo your whole FA install.

this is quite weird TBH. never had this. what change happened on your setup before it started failing?

0

I'm testing new proton 5.13, everything's nominal

1

Hi everyone,
I'm trying to install downlords faf client on linux. But i'm having problems with java installation.
When i follow the wiki and install openjdk-14-jre (and do all the other steps) i get the following output when trying to run the client:
No suitable Java Virtual Machine could be found on your system.
The version of the JVM must be 15.
Please define INSTALL4J_JAVA_HOME to point to a suitable JVM.

I then tried installing version 15 and setting the env-var with the following:
export INSTALL4J_JAVA_HOME=/usr/lib/jvm/java-15-openjdk-amd64
I also tried to install the oracle java package (as in video tutorial) but i could not get it to install at all.

I am not very experienced in linux... does anyone know what i'm doing wrong?

0

@JuicyWishes said in Linux Support:

Hi everyone,
I'm trying to install downlords faf client on linux. But i'm having problems with java installation.

open up one terminal window.
first command:
export INSTALL4J_JAVA_HOME=/usr/lib/jvm/java-14-openjdk-amd64
second command:
./downlords-faf-client

do you do this or something else?

EDIT
sorry, the client needs java15 now?

0

btw i have switched to Windows 10 in this month.
im not proud of this.
but i had basic stability problems constantly. with my recent set up too: PopOS LTS + Gnome3 + AMD drivers.
i dont know why, i have no time to experiment with other things. Win 10 is stable.

so i cannot test the game on linux from now on.
if someone wants to update the wiki from now on, go ahead!
https://wiki.faforever.com/index.php?title=Setting_Up_FAF_Linux